We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33579
    • 52 Posts
    Bonjour à tous,

    J’avais posté ce message dans mon autre topic Petit soucis pour comprendre DropMenu mais je me suis dit qu’il n’y avais plus trop de rapport avec la choucroute, alors je créer un nouveau message pour mon problème.

    Suite à la discution de ce topic j’ai installé la beta 0.9.5 afin d’avoir le doc manager.

    Ma configuration :

    EasyPHP 1.8
    MoDx 0.9.5 RC2

    J’ai donc fais une nouvelle installation (pas un upgrade) pour être sur de faire la chose proprement, tout s’est passé sans soucis.
    L’administration à l’air de fonctionner bien sauf....... le doc manager grin huh

    lorsque je vais dans module -> doc manager -> template variable afin de définir une TV à appliquer à un dossier et tous les sous-dossiers qu’il contient, je séléctionne le template que je veux et en dessous j’ai :


    Warning: main(MODX_BASE_PATHmanager/includes/config.inc.php): failed to open stream: No such file or directory in c:\web\easyphp1-8\www\monSite\modx\assets\modules\docmanager\includes\tv.ajax.php on line 12

    Warning: main(): Failed opening ’MODX_BASE_PATHmanager/includes/config.inc.php’ for inclusion (include_path=’.;C:\Web\EASYPH~2\\php\pear\’) in c:\web\easyphp1-8\www\monSite\modx\assets\modules\docmanager\includes\tv.ajax.php on line 12

    Warning: main(MODX_BASE_PATHmanager/includes/document.parser.class.inc.php): failed to open stream: No such file or directory in c:\web\easyphp1-8\www\monSite\modx\assets\modules\docmanager\includes\tv.ajax.php on line 13

    Warning: main(): Failed opening ’MODX_BASE_PATHmanager/includes/document.parser.class.inc.php’ for inclusion (include_path=’.;C:\Web\EASYPH~2\\php\pear\’) in c:\web\easyphp1-8\www\monSite\modx\assets\modules\docmanager\includes\tv.ajax.php on line 13

    Fatal error: Cannot instantiate non-existent class: documentparser in c:\web\easyphp1-8\www\monSite\modx\assets\modules\docmanager\includes\tv.ajax.php on line 14


    help huh
      • 27889
      • 415 Posts
      Vérifie dans la configuration que les chemins sont corrects (tool- configuration ) réglage interface et réglage éditeur.
      Vérifie que les fichiers générants les erreurs soient bien présents.
      Ceci aussi est bizarre :
      (include_path=’.;C:\Web\EASYPH~2\\php\pear\’)

      si tu utilises l’url rewriting as-tu bien renommer les fichiers ht.access en .htaccess et modifié dedans le répertoire d’installation de modx ?
        MODx Sites & Prestations: http://dp-site.fr [Last MODx Site]
        MODx Repository: [HOME] [MetaTagsExtra] / Current Dev: [xFDM]
        • 33579
        • 52 Posts
        ce qui est étrange, c’est qu’il n’a pas l’air d’aller chercher ce que contienut MODX_BASE_PATH.

        Dans tv.ajax.php au début du code il y a :

        include_once(MODX_BASE_PATH."manager/includes/config.inc.php");
        include_once(MODX_BASE_PATH."manager/includes/document.parser.class.inc.php");
        


        lorsque je fais
        echo MODX_BASE_PATH
        juste avant il me trace :
        MODX_BASE_PATH
        au lieu de me tracer le chemin défini dans le config.inc.php....

        C’est étrange, j’ai essayé de mettre les path à la main :

         include_once("http://localhost/monSite/modx/manager/includes/config.inc.php");
         include_once("http://localhost/monSite/modx/manager/includes/document.parser.class.inc.php");
        


        en faisant ça, il me sort :
        Fatal error: Cannot instantiate non-existent class: documentparser in c:\web\easyphp1-8\www\alternative_planetaire\modx\assets\modules\docmanager\includes\tv.ajax.php on line 16

        Pourtant j’ai vérifié la présence de document.parser.class.inc.php, il est bien au bon endroit....

        Ca commence à me faire peur tout ça, j’espere qu’il y a une solution à mon problème. Est-ce que cela peut venir du fait que je suis en utf-8 ?

        EDIT : Je viens de tester une installation toute neuve de modx 0.9.5 RC2. Une fois l’installation terminée, je vais direct dans le doc_manager et hop, meme erreur que plus haut. Ca m’étonne donc que je semble être le seul à rencontrer cette erreur. A moins que je sois un des seul à essayer de faire marcher le docmanager ^^

        En tout cas ca veut déjà dire que cela ne vient pas de l’UTF-8

        D’autres idées ?
          • 11975
          • 2,542 Posts
          Salut,

          pb identique chez moi dans l’onglet Template variables
          Une fois que je sélectionne la template, j’ai le même message d’erreur.

          je vais regarder si il y a un bug report à ce sujet

          :-)
            Made with MODx : [url=http://www.copadel.com]copadel, fruits et l
            • 11975
            • 2,542 Posts
            J’ai rapporté le bug
            garryn m’a répondu que le fix était inclus dans la version SVN

            :-)
              Made with MODx : [url=http://www.copadel.com]copadel, fruits et l
              • 33579
              • 52 Posts
              euh... ok, pardonne moi mon ignorance, mais c’est quoi la verision SVN ? et ou peut on se la procurer ?
                • 33579
                • 52 Posts
                ok, j’ai pris un peu de temps à chercher sur le forum pour la version SVN.... (j’ai pas trouvé super facilement, je suis pas très doué en mot clés de recherche pour les forums) ^^

                donc pour ceux qui ne savent pas, parce que je ne pense pas être le seul... les version SVN c’est des version "pré-beta" uniquement disponible aux développeurs.

                Donc pour le moment, l’erreur du doc manager est insolvable, le mieux est d’attendre la sortie du prochain doc manager qui corrigera ce bug si j’ai rien compris.

                J’espere qu’il sortira rapidement, je suis sensé mettre le site en ligne en fin de semaine undecided grin
                  • 20488
                  • 353 Posts
                  Oula oui... éviter à tout prix de passer en production un site en SVN ! laugh.
                  La RC-2 ne te convient pas ? Elle me paraît stable pourtant. Cela dit je n’ai pas regardé les ammélioration de la dernière SVN.
                    • 33579
                    • 52 Posts
                    Ben si, la RC2 me convient parfaitement, excepté ce problème avec doc manager, et j’ai besoin absolument des possibilités qu’il offre pour appliquer des choses à toutes mes pages (sans les éditer 1 par 1 à la main)...

                    Donc il faut que le nouveau doc manager sorte rapidement ^^
                      • 33579
                      • 52 Posts
                      Bon, le problème semble résolu dans la version 0.9.5 RC3 donc je vous conseil de faire la mise à jour. ^^