We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28173
    • 409 Posts
    Hello,

    J’essaie d’installer MODx 0.9.5 chez mon hébergeur.
    J’ai donc uploadé tous les fichiers de l’archive et suivit la procédure d’installation dispo ici : http://wiki.modxcms.com/index.php/Installation_Guide

    Malheureusement, qd je vais dans le répertoire /install, j’obtiens une belle erreur "500 Internal Server Error"
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    Je précise que je n’ai pas activé le fichier .htaccess à la racine du site.

    Une idée d’où ça pourrait provenir ?
      • 18219
      • 826 Posts
      Pourrais-tu nous donner plus d’informations au sujet de ton hébergement ?
      Notamment les lignes d’erreurs qui se sont inscrites dans ton fichier log au moment de l’installation.

      Une des fonctions habituellement installées dans une configuration standard de PHP n’est pas présente dans ton cas est provoque cette erreur interne.

      Si tes connaissance en la matière sont insuffisante, demande au support de ton hébergeur de t’indiquer les origines de cette erreur.
      Nous pourrons t’aider ensuite.
        Marc
        I'm French... Sorry for my bad English, I use ' Google Translator' or other... but that remains that tools wink
        • 28173
        • 409 Posts
        Je suis justement en attente du fichier de log.
        Je vous tiens au courant smiley
          • 28173
          • 409 Posts
          29-14 = 15... 15 jours plus tard, je parviens enfin à mettre la main sur le log du serveur !
          Ouf !

          Donc voici ce qu’il dit lorsque je tente d’installer MODx :
          [Mon Jan 29 23:31:28 2007] [error] [client 101.147.21.82] Premature end of script headers: /home/mydomain/www/install/index.php


          Après une petite recherche sur le net, je constate que c’est une erreur courante :
          Lorsque je lance un script CGI, j’obtiens une erreur 500, que puis-je faire ?
          ==================================================
          Vérifiez le type de message d’erreur présent dans votre fichier error_log :
          Si vous avez un message du type "Premature end of script headers", il manque probablement les en-tête HTTP : pensez à mettre une ligne du type print "Content-type: text/html\n\n"; au début de votre script.
          Le soucis, c’est que je n’ai aucune idée de comment vérifier ce qu’ils disent....
          D’autant plus que a semble concerner des scripts CGI et il ne me semble pas en avoir vu dans MODx...

          Donc si quelqu’un a une idée...
            • 28173
            • 409 Posts
            Dans la doc officielle d’Apache on trouve ceci :
            What does it mean when my CGIs fail with "Premature end of script headers"?
            ==================================================

            It means just what it says: the server was expecting a complete set of HTTP headers (one or more followed by a blank line), and didn’t get them.

            The most common cause of this problem is the script dying before sending the complete set of headers, or possibly any at all, to the server. To see if this is the case, try running the script standalone from an interactive session, rather than as a script under the server. If you get error messages, this is almost certainly the cause of the "premature end of script headers" message. Even if the CGI runs fine from the command line, remember that the environment and permissions may be different when running under the web server. The CGI can only access resources allowed for the User and Group specified in your Apache configuration. In addition, the environment will not be the same as the one provided on the command line, but it can be adjusted using the directives provided by mod_env.

            The second most common cause of this (aside from people not outputting the required headers at all) is a result of an interaction with Perl’s output buffering. To make Perl flush its buffers after each output statement, insert the following statements around the print or write statements that send your HTTP headers:

            {
            local ($oldbar) = $|;
            $cfh = select (STDOUT);
            $| = 1;
            #
            # print your HTTP headers here
            #
            $| = $oldbar;
            select ($cfh);
            }

            This is generally only necessary when you are calling external programs from your script that send output to stdout, or if there will be a long delay between the time the headers are sent and the actual content starts being emitted. To maximize performance, you should turn buffer-flushing back off (with $| = 0 or the equivalent) after the statements that send the headers, as displayed above.

            If your script isn’t written in Perl, do the equivalent thing for whatever language you are using (e.g., for C, call fflush() after writing the headers).

            Another cause for the "premature end of script headers" message are the RLimitCPU and RLimitMEM directives. You may get the message if the CGI script was killed due to a resource limit.

            In addition, a configuration problem in suEXEC, mod_perl, or another third party module can often interfere with the execution of your CGI and cause the "premature end of script headers" message.
            Mais même topo : comment m’y prendre pour savoir d’où vient le problème et comment le corriger ?
              • 28173
              • 409 Posts
              Le problème pourrait-il venir de mon hébergeur (limite d’exécution d’un script etc...) ?
                • 28173
                • 409 Posts
                Problème résolu !
                Le problème venait en fait de droits qui étaient trop laxistes sur certains répertoires. Mon hébergeur ayant fait en sorte que dans ces cas là, une erreur 500 apparaisse.
                La solution a été de mettre les droits 705 sur certains répertoires et fichier, notamment /manager et /manager/processors/

                Si ça peut aider smiley