We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 10050
    • 1 Posts
    Au secours,
    je ne comprends pas pourquoi google rejette les pages de ce site.
    Les simulateurs de robots indiquent une erreur 500, bien que le site s’affiche normalement.
    Idem pour construire un Google sitemap : seul les pages qui sont en fait des fichiers .pdf sont reconnus toutes les autres sont ignorées. Donc impossible de contourner le pb.
    Cela vient-il du htaccess.
    QQ’un a t-il eu ce problème ??
    J’ai mis le rewriting simple avec postfixe html (sans le postfixe ça le faisait déjà)

    L’adresse du site :
    http://www.atreya.com/fr/a-propos/institut.html
    attention : j’ai passé la page accueil (http://www.atreya.com) en pure html pour que google l’accepte au moins
    Mais toutes les autres pages ont ce défaut d’être lu par les robots en erreur 500 bien qu’elle s’affichent.

    Merci d’avance
      • 2472
      • 151 Posts
      [tt]<html lang="en" xml:lang="en" xmlns="http://www.w3.org/1999/xhtml">[/tt]

      Alors que tes pages sont en français... Je dis pas que c’est la cause de ton problème mais ça me chiffone quand même.
        A thing of beauty is a joy forever ( John Keats)
        • 20660
        • 3 Posts
        Bonjour,

        je viens tout juste d’arriver sur ce forum et comme je suis en train de faire des tests pour sélectionner un cms qui me conviendrait (entre autre modx) je suis passée par le forum pour poser quelques questions.

        Ce message présentement m’a interpellé puisque l’url rewriting est un point indispensable pour finaliser mon choix, alors j’ai ouvert le topic pour constater le bug reporté.

        Quand je me suis rendue sur l’adresse indiquée pour voir le comportement de la page et tenter de comprendre le problème et pouquoi google la rejette :
        http://www.atreya.com/fr/a-propos/institut.html

        J’ai eu la surprise dans ma barre d’adresse de voir ça :
        http://www.atreya.com/fr/a-propos/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/ayurveda/index.php

        Alors effectivement google .... Il ne va jamais la prendre cette url !

        Y a un truc qui boucle quelque part (voir peut etre du coté du htaccess, l’adresse a peut être été mal écrite dedans (si modx le fait tout seul comme un grand ...) par contre j’ai vu que le site était sous Spip, cela signifie que modx n’a pas retenu ton attention François26 ?

        A disposition pour plus d’infos smiley

        Je reste dans le coin, j’ai une question qui tien en trois tomes à poser sur Modx dans une autre rubrique !

        Bye,

        Murrigane
          • 36624
          • 535 Posts
          et oui le site est en spip... j’espère que c’est pas a cause de cette simple erreur 500 quand même... smiley

          je dis "simple" car j’ai eu quelques problèmes d’erreur 500 sur des sites récents et bien que je n’ai pas trouvé une raison claire à ces erreurs, elles se sont toutes résolues en désactivant certains plugins sous certaines situations.. par exemple, le highlightplugin.. ou même phx sur un autre, je peux difficilement être plus précis car a chaque fois je bidouille aussi dans tout les coins et au final je me rappelle plus très bien..

          un moyen simple de détecter ces erreurs 500 c’est d’envoyer la page au validator W3C, c’est radical.

          cheers,
            CTRL+SHIFT+U - Clear Cache
            CTRL+SHIFT+H - Hiding Heft Panel
            CTRL+SHIFT+N - Fast Create Resource
            CTRL+ALT+P - Preview Recource (in edit resorce window)
            CTRL+ALT+S - Save
            • 10449
            • 956 Posts
            T’as trop de redirects 302; c’est le message du validateur W3C:

            I got the following unexpected response when trying to retrieve <http://www.atreya.com/fr/a-propos/institut.html>:

            302 Found

            More information about why this is happening may be available from warnings reported by the validator’s HTTP (and other protocol) client library:

            Redirect loop detected (max_redirect = 7)

            Faut contrôler les .htaccess files, et peut-être aussi les redirect snippets comme FirstChildRedirect, et les alias de tes documents...