We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 11636
    • 47 Posts
    Bien le heu a cette heure ci bonsoir smiley
    Bon tout d’abord un petit remerciment a cette exelent cms qui me satisfait depuis 1an maintenant même si la future version ce fait désirer depuis un petit bou de temps.

    résumé :probleme passage local en ligne et on fait comment une maj de la 0.9.6.0 a 0.9.6.1


    donc voilà mon site ce veillissant j’ai fait l’appel a un webdesigner pour me rafrachir tout ca jusque la tout va bien donc son travail finni je doit faire l’integration a modx pour ce faire je prefere le faire dans mon coin en local je rapatri donc ma base de donné et mes ficheirs je test et la erreur (j’ai changé l’accé a la base de donné dans config.inc.php

    l’erreur étant celle-ci "MODx is not currently installed or the configuration file cannot be found."

    la version longue
    1) $noparser = true; // get start time $mtime = microtime(); $mtime = explode(" ",$mtime); $mtime = $mtime[1] + $mtime[0]; $tstart = $mtime; // harden it require_once(dirname(__FILE__).'/manager/includes/protect.inc.php'); // set some settings, and address some IE issues @ini_set('url_rewriter.tags', ''); @ini_set('session.use_trans_sid', 0); @ini_set('session.use_only_cookies',1); session_cache_limiter(''); header('P3P: CP="NOI NID ADMa OUR IND UNI COM NAV"'); // header for weird cookie stuff. Blame IE. header('Cache-Control: private, must-revalidate'); ob_start(); error_reporting(E_ALL & ~E_NOTICE); /** * Filename: index.php * Function: This file loads and executes the parser. * */ define("IN_ETOMITE_PARSER", "true"); // provides compatibility with etomite 0.6 and maybe later versions define("IN_PARSER_MODE", "true"); define("IN_MANAGER_MODE", "false"); // initialize the variables prior to grabbing the config file $database_type = ''; $database_server = ''; $database_user = ''; $database_password = ''; $dbase = ''; $table_prefix = ''; $base_url = ''; $base_path = ''; // get the required includes if($database_user=="") { $rt = @include_once(dirname(__FILE__).'/manager/includes/config.inc.php'); // Be sure config.inc.php is there and that it contains some important values if(!$rt || !$database_type || !$database_server || !$database_user || !$dbase) { echo "
    
    MODx is not currently installed or the configuration file cannot be found.
    
    Do you want to install now?
    "; exit; } } // start session startCMSSession(); // initiate a new document parser include_once(MODX_MANAGER_PATH.'/includes/document.parser.class.inc.php'); $modx = new DocumentParser; $etomite = &$modx; // for backward compatibility // set some parser options $modx->minParserPasses = 1; // min number of parser recursive loops or passes $modx->maxParserPasses = 10; // max number of parser recursive loops or passes $modx->dumpSQL = false; $modx->dumpSnippets = false; // feed the parser the execution start time $modx->tstart = $tstart; // Debugging mode: $modx->stopOnNotice = false; // Don't show PHP errors to the public if(!isset($_SESSION['mgrValidated']) || !$_SESSION['mgrValidated']) @ini_set("display_errors","0"); // execute the parser if index.php was not included if(!$noparser) $modx->executeParser(); exit; ?>



    et de plus j’aimerais profiter de cette occasion pour mettre la version 0.9.6.1 mais je n’ai trouvé comment on fait un update? on écrase le répertoire? il faut éxécuter un certain script?


    Et si en + dans tout ca je pouvez avoir quelque date comme la version 0.9.7? tatoo? et enfin modxcms.fr?


    je ne fait que passer de temps a autre mais de tete je dirais merci a aour david perrine ...... et la parti anglaise aussi que je ne lis :’( donc merci a tous pour votre contribution a ce magnifique outil bonne soirée.
      • 11636
      • 47 Posts
      ca avance un peu en enlevant mon .htaccess j’ai acces a la page d’acceuil qui n’a plus de mise en page et quand je clique sur un lien ca pointe vers la version en ligne.

        • 36624
        • 535 Posts
        salut,
        pour faire une mise ajour (update) 096>0961 :

        1) tu backup ta db
        2) tu duplique ton fichier de config.php.inc
        3) tu reupload le dossier complet en écrabouillant le tout.^^
        4) tu relance l’install /install
        ... et le cms doit te proposer de faire une mise à jour.

        pour le passage en local c’est pareil

        ps: si y a un soucis tu peux toujours créer un config.php.inc vide que modx se chargera de remplir au moment de l’install..

        j’espère que ça t’aidera.
        a+
          CTRL+SHIFT+U - Clear Cache
          CTRL+SHIFT+H - Hiding Heft Panel
          CTRL+SHIFT+N - Fast Create Resource
          CTRL+ALT+P - Preview Recource (in edit resorce window)
          CTRL+ALT+S - Save
          • 11636
          • 47 Posts
          Merci la mise à jourt c’est fait correctement par contre j’ai topujours mon souci quand je passe en local

          donc j’ai modifier le .htaccess pour passer de
          RewriteEngine On
          RewriteCond %{REQUEST_FILENAME} !-f
          RewriteCond %{REQUEST_FILENAME} !-d
          RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA]
          AddType x-mapp-php5 .php  



          a
          RewriteEngine On
          RewriteCond %{REQUEST_FILENAME} !-f
          RewriteCond %{REQUEST_FILENAME} !-d
          RewriteRule ^(.*)$ /modx/index.php?q=$1 [L,QSA]


          mais la page d’acceuil tourne par contre nimporte quel lien donne Internal Server Error

          The server encountered an internal error or misconfiguration and was unable to complete your request.

          Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

          More information about this error may be available in the server error log.

          et auriez vous des information sur la version 0.9.7? tatoo? et enfin modxcms.fr?


          en tout cas merci pour la mise a jour et j’ai peu constater également votre aide sur un autre topic smiley bonne soirez je m’en vais essayer de construire mes menu.
            • 11636
            • 47 Posts
            bon je test directement en ligne donc plus de souci en essayant sur un autre template

            par contre je prend des info sur et auriez vous des information sur la version 0.9.7? tatoo? et enfin modxcms.fr?


            n’ayant pas été totalement résolu je marque tt de même résolu?

              • 23050
              • 1,842 Posts
              Hello smiley

              Pour le problème de la consultation en ligne, as-tu bien le mod rewrite activé en local ? Tu utilises quel outil pour le local ?

              Si ça ne marche pas toujours, ça ne t’empêche pas de désactiver la réécriture d’url dans l’admin et tu la réactiveras une fois en ligne smiley
                • 11636
                • 47 Posts
                mod rewrite activé j’utilise wamp avec module apache rewrite_module activé

                oui vais désactiver url s’implifier en local car pour mon autre souci de menu je doit modifier les chemins .. donc juste jonglet entre 2 template ne fonctionne pas.