We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 2327
    • 214 Posts
    Horreur malheur...en modifiant la config utilisateur du manager (j’ai coché accès racine et ajouté l’extension jpg pour les fichiers uploadable, mon interface Manager s’est toute cassée..et ensuite un message d’erreur renvoyant à
    manager/includes/accesscontrol.inc.php

    J’ai plus rien qui marche et impossible de modifier ou copier/coller ce fichier fichier. Un pb de cache ? J’ai mis les permissions à 777 sur Include et le fichier mais rien n’y fait.

    Not Logged In! c’est le message lorsque je tente de me logguer au manager....et plus rien en Front End.

    Au secours !
      • 6726
      • 7,075 Posts
      Message d’erreur SVP ?
      Un copier coller histoire qu’on sache d’où vient le souci...

      A mon avis tu devrais commencer déjà par regarder si ce n’est pas un problème de cookie bloqué (détruit les cookies du site en question via ton navigateur). Si ça ne marche pas c’est peut-être aussi un problème de session, idem nettoyer via le navigateur. Enfin si rien de tout ça ne marche, faire un tour dans phpMyAdmin et vérifier que la table utilisateur est cohérente...
        .: COO - Commerce Guys - Community Driven Innovation :.


        MODx est l'outil id
        • 2327
        • 214 Posts
        Merci David..non, j’ai bien vidée tous les cache et cookies...le message d’etteur qu’il affichait (il ne l’affiche plus était un truc d’echec de fonction en ligne 130 du manager/include/ accesscontrol.inc.php.

        Mais bizarrement, impossible de modifer ce fichier fia FTP, même en changeant les droits...une histoire avec le repertoire Cache de Assets ? C’est ce que j’ai cru comprendre en surfant sur les forums.

        Maintenant, je n’ai pour seul message que Not Logged In! dans le rep Manager, et Rien du tout dans la racine. Bizarre ?

        Bon, peut-être une mise à jour me sauvera la mise ?

        Inquiétant !

        Je viens de vérifier et d’optimiser les tables via PHPMYADMIN. Tout baigne , sauf ce message :
        il y a des problèmes avec les index de la table `modx_site_content`
        Les index suivants semblent équivalents, vous devriez en éliminer un. PRIMARY, id


        Mais ce ne semble pas être la cause ! Merci en tout cas de ton aide.
          • 2327
          • 214 Posts
          Voilà, j’ai réussi a reproduire l’erreur en recopiant le fichier accesscontrol.inc.php d’origine (j’ai remplacé le nom de mon accès par xxxx :

          Warning: fopen(/home/xxxx/public_html/rc3/manager/media/style//login.html) [function.fopen]: failed to open stream: No such file or directory in /home/xxxx/public_html/rc3/manager/includes/accesscontrol.inc.php on line 129

          Warning: filesize() [function.filesize]: stat failed for /home/xxxx/public_html/rc3/manager/media/style//login.html in /home/xxxx/public_html/rc3/manager/includes/accesscontrol.inc.php on line 130

          Warning: fread(): supplied argument is not a valid stream resource in /home/xxxx/public_html/rc3/manager/includes/accesscontrol.inc.php on line 130

          Warning: fclose(): supplied argument is not a valid stream resource in /home/xxxx/public_html/rc3/manager/includes/accesscontrol.inc.php on line 131




          Et les lignes 127 à 131 du fichier accesscontrol.inc.php contiennent :

          127 // load template file
          128 $tplFile = $base_path.’manager/media/style/’.$manager_theme.’/login.html’;
          129 $handle = fopen($tplFile, "r");
          130 $tpl = fread($handle, filesize($tplFile));
          131 fclose($handle);


          Au secours... huh huh huh
            • 2327
            • 214 Posts
            David..tu peux mettre résolu.

            En fait, j’ai simplement fait une re-install / mise à jour et tout est rentré dans l’ordre. La procédure de mise à jour est vraiment au point sur la 9.6 ! Un plaisir.

            Si tu repasse par là, pourrais-tu jeter un coup d’oeil sur ce post :
            http://modxcms.com/forums/index.php/topic,18968.new.html#new

            car je crois comprendre au vu des lectures du Forum que tu connais bien ce sujet smiley

            Merci en tout cas.