We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28173
    • 409 Posts
    Bonjour,

    J’ai le log des erreurs de mon site qui se rempli à vitesse grand V et je suis incapable de savoir par où chercher pour résoudre le pb.
    Voici l’erreur :
    PHP Parse error:  syntax error, unexpected T_STRING in /home/monsite/www/manager/includes/document.parser.class.inc.php(766) : eval()'d code on line 128

    Auriez-vous une idée sur la marche à suivre pour débugguer ça ?
      • 28173
      • 409 Posts
      Visiblement, il s’agit d’une simple erreur de ";" ou de guillemet : http://www.commentcamarche.net/faq/sujet-869-php-parse-error-unexpected-t-string-expecting-or
      Mais où chercher huh?
      La ligne 766 du fichier document.parser.class.inc.php laisse supposer qu’il s’agirait d’un Snippet... mais lequel !!???
        • 28173
        • 409 Posts
        Up smiley

        J’ai vérifié tous mes snippets pour voir si les codes <?php et ?> étaient bien présents de manière correcte.
        Ca semble bon...
        Ce qui me scie, c’est le manque d’info présent dans le message d’erreur. N’y a-t-il pas moyen d’avoir quelque chose de plus prolixe ?
          • 11975
          • 2,542 Posts
          Salut,

          l’erreur est à chercher ligne 128 d’un de tes snippets.
          Est ce que l’erreur se produit pour chaque page ?
          Desactive l’un après l’autre tes snippets, à chaque fois recharge la page et vérifie la presence du message d’erreur.
          Si il est tjs là continue jusqu’à identifier le coupable.

          :-)
            Made with MODx : [url=http://www.copadel.com]copadel, fruits et l
            • 28173
            • 409 Posts
            J’ai regardé à la ligne 128 des principaux snippets que j’utilise.
            Rien à signaler au niveau syntaxique.
            Par contre chose étrange :
            - qd le site est en ligne (tout le monde peut y accéder), la ligne d’erreur n’arrête pas de s’inscrire dans le log
            - qd le site est hors ligne (seul moi qui suis logué dans le manager peut y accéder), la ligne d’erreur n’apparaît pas dans le log

              • 16732
              • 592 Posts
              Comme te le signale Helio, identifies sur quelles pages se produit l’erreur, regardes le snippet (sûrement custom) commun à ces pages et vérifies la ligne 127
                • 28173
                • 409 Posts
                Je pense avoir résolu la moitié du problème.
                J’utilisais l’astuce de la TV [*setdatelocalefr*] pour franciser les dates en français.
                Visiblement, une fois l’appel de la TV enlevé, la charge processeur du serveur est redevenue normale : le processus php du serveur montait à 50-60% avec la TV et chute à 0.3% sans.
                De plus, la fameuse ligne d’erreur posté ci-dessus apparaît maintenant 2 fois moins.

                Mais elle apparaît toujours !

                J’ai donc passé le site hors ligne, afin d’être le seul à pouvoir y accéder.
                Pas moyen de faire apparaître cette ligne d’erreur dans le log en affichant une à une les pages du site.

                PAR CONTRE, et ça c’est cocasse, sur le site il y a un forum Invision Board qui n’a (j’ai revérifié) RIEN à voir avec les scripts de MODx. Je n’ai trouvé aucun lien, aucun appel....
                MODx est installé à la racine du site et le forum est situé dans le répertoire /forum du site.
                Lorsque le site était hors ligne, le forum fonctionnait toujours, et aucune ligne d’erreur ne s’affichait dans le log.
                C’est là que ça devient paranormal : lorsque JE vais sur le forum, le log enregistre l’erreur. A chaque rafraîchissement du forum, la ligne d’erreur d’affiche, indiquant tjrs le même pb lié au fichier document.parser.class.inc.php, fichier pourtant intimement lié à MODx et nullement à Invision Board !

                Complètement désappointé par ce constat surréaliste, j’ai tenté de remettre le site en ligne : les lignes d’erreurs sont réapparues, moins nombreuses qu’avant la suppression de l’appel à la TV setdatelocalefr, mais tjrs présentes....

                Et c’est à ce moment là que je suis passé à autre chose....