On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Aamupäivää,

    Olen asennellut useammankin ModX:n ja saanut selkokieliset osoitteet toimimaan todella hienosti. Mutta vain jos olen luonut ModX:lle oman kansion (esim. www.domain.fi/modx). Haluaisin saada ModX:n toimimaan selkokielisillä osoitteilla suoraan www.domain.fi -osoitteessa.

    .htaccessissa on tullut kokeiltua jos jonkinlaisia virityksiä, mutta ei. Se ei ole vahvinta alaani. Googlellakaan en ole onnistunut löytämään ratkaisua.

    Jelppiä kaivatan,
    Sami
    • Normaalisti mitään muuta ei tarvita kuin MODx -asennuksen juuressa olevan ht.access -tiedoston uudelleennimeäminen .htaccess -tiedostoksi.

      .htaccess -tiedostossa on oletuksena rivi
      RewriteBase /

      joka tarkoittaa sitä, että MODx on asennettu palvelimen html -kansion juureen.

      Saatko jonkin virheilmoituksen vai miten tuo selkokielisten osoitteiden toimimattomuus tulee ilmi yrittäessäsi asentaa MODx:n palvelimen juureen?
        Mikko Lammi, Owner at Maagit
      • Quote from: Lammikko at Jun 19, 2010, 09:30 AM

        Saatko jonkin virheilmoituksen vai miten tuo selkokielisten osoitteiden toimimattomuus tulee ilmi yrittäessäsi asentaa MODx:n palvelimen juureen?

        Domain.fi toimii moitteetta, mutta sitten kun klikkaan linkkiä, jonka pitäisi viedä selkokielisenä osoitteeseen domain.fi/alias niin tulee 404 virhesivu. Ja tämä on tapahtunut kaikilla sivuilla, joille modX:n asentanut.

        Tässä vielä .htaccess tiedosto joka minulla on;

        # For full documentation and other suggested options, please see
        # http://svn.modxcms.com/docs/display/MODx096/Friendly+URL+Solutions
        # including for unexpected logouts in multi-server/cloud environments
        # and especially for the first three commented out rules
        
        #php_flag register_globals Off
        #AddDefaultCharset utf-8
        #php_value date.timezone Europe/Moscow
        
        Options +FollowSymlinks
        RewriteEngine On
        RewriteBase /
        
        # Fix Apache internal dummy connections from breaking [(site_url)] cache
        RewriteCond %{HTTP_USER_AGENT} ^.*internal\ dummy\ connection.*$ [NC]
        RewriteRule .* - [F,L]
        
        # Rewrite domain.com -> www.domain.com -- used with SEO Strict URLs plugin
        #RewriteCond %{HTTP_HOST} .
        #RewriteCond %{HTTP_HOST} !^www\.tassadomain\.fi [NC]
        #RewriteRule (.*) http://www.tassadomain.fi/$1 [R=301,L]
        
        # Exclude /assets and /manager directories from rewrite rules
        RewriteRule ^(manager|assets) - [L]
        
        # For Friendly URLs
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
        
        # Reduce server overhead by enabling output compression if supported.
        #php_flag zlib.output_compression On
        #php_value zlib.output_compression_level 5
        • Ei tuossa .htaccess -tiedostossa ainakaan vaikuttaisi olevat mitään ihmeellistä, joka estäisi toiminnan. Kokeile varmuudeksi MODx:n oletusasennuksen mukana tulevalla .htaccess -tiedostolla, jos vaikka sekaan olisi eksynyt jokin ylimääräinen merkki tai vastaava, joka ei nyt osu silmään.

          Jos ei vieläkään toimi, ota yhteyttä web-hotellin palveluntarjoajaan ja tiedustele onko palvelimella jotain tavallisesta poikkeavia asetuksia Apachen mod_rewriten suhteen.
            Mikko Lammi, Owner at Maagit