We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22435
    • 16 Posts
    Very strange. Maxigallery has always treated right, and I am always amazed at how phenomenally well-built and extensible it is, but... this time I can’t quite figure out what’s wrong.

    No matter the type of call, or whether using the front- or back-end managers, and through all permutations of caching, I can’t upload or resynch any pictures.

    Front-end Manager: I click on the Manage Pictures button and get the notification "This web page is being redirected to a new location. Would you like to resend the form data you have typed to the new location?" and after the redirect there is no Manage Pictures button or upload form.

    Back-end manager: I get the whole upload form in the tab, no problems. When using the flash uploader, nothing happens when I click the Upload Pictures button. When using the normal upload form, I can browse for and select an image file, and when Upload is clicked it sends the request to the page and seems to upload the file, but no images are there after the process.

    I really thought it was the snippet calls, but after triple-checking and changing all back-ticks and combinations of caching and uncaching in the managing and target calls, I am at a loss.

    Now, there may be a complication: I am using YAMS on a bi-lingual site. But the problem seems to be in the form action for uploading pictures.

    Thanks for any suggestions in advance. Any thoughts?
      • 7923
      • 4,213 Posts
      Could it be some server configuration issue?

      Or have you run maxigallery succesfully on that server?

      Quite hard to start figuring out what’s the problem..

      If you call it simply using [!MaxiGallery!] on some document, view the document in website front end, hit manage pictures button and it doesn’t show the picture management form, then that’s totally bizarre to me.

      If it does show the picture management form and you upload an image, it is possible that you hit max script runtime or memory limits on your server if the picture doesn’t show up. In this case, see the server configuration parameters from MaxiGallery wiki article.

      Also check your apache error logs to see if there’s something happening.. and see the logs in MODx manager. Aslo check what is the PHP error reporting level and try to raise it if you don’t see any errors anywhere.

      It could simply be that all error reporting is off and php complains about the deprecated split() function.

      Also check the sticky topic for possible parsing errors.


        "He can have a lollipop any time he wants to. That's what it means to be a programmer."
        • 22435
        • 16 Posts
        Doze, thanks for those suggestions; I will check the server configuration and error logs when I am back at a computer on Monday. I am running 5 MODx sites on the same server and all have Maxigallery and everything else working just fine. I tried changing split to explode and back again, and it doesn’t seem to be throwing up parsing errors, but I will look deeper into the logs and see if it just isn’t reporting them. Given your response, my inclination is maybe towards YAMS having something to do with it, but... I dunno. I’ll let you know what comes up next week.

        Thanks again for your response -- and Maxigallery, generally. This one is baffling.
          • 22435
          • 16 Posts
          GREAT GOOGLY MOOGLY! That was a long and arduous process with a totally anti-climactic resolution! Sound and fury signifying nothing, I’ll you what...

          So. Issue resolved. As promised, I am reporting what I discovered and my solution, although, honestly, it just proves that I don’t know as much as I thought and that a little knowledge sure as sheet is a dangerous thing.

          I checked all the logs and even tried screwing up some of the object calls to see if I could provoke intentional parsing errors and all seemed totally normal. Turns out, it WAS a YAMS issue -- but not an issue of interoperability between YAMS and Maxigallery. It WAS simply my fault: in the URL Formatting settings, I had not specified a MODx subdirectory (MODx/) because the .htaccess file was redirecting everything correctly already. Turns out the YAMS does its own redirection, and it was sending my Upload Pictures submissions off into the ether.

          Thank you again a thousand times, Doze, for offering your feedback. The problem turned out to just be me, but the offer of support was invaluable!
            • 7923
            • 4,213 Posts
            Good that you got it resolved and thanks for the report.. I’ll sure help others battling with the same thing.


              "He can have a lollipop any time he wants to. That's what it means to be a programmer."