We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 8416
    • 173 Posts
    Hello,
    I’m getting an out-of memory error when I try to upload picture via Maxigallery although I have redifined the upload max value. Does any one know what’s happening?
    Fatal error: Out of memory (allocated 34865152) (tried to allocate 2736 bytes) in /homepages/xx/xxxxx/htdocs/assets/snippets/maxigallery/watermark/Thumbnail.class.php on line 183


    In my php.ini I have the following setting:
    [php]
    memory_limit = 300M     
    upload_tmp_dir =/tmp
    upload_max_filesize = 30M
    post_max_size = 20M

    Thank you

      • 22303 MODX Staff
      • 10,725 Posts
      It looks like you are trying to upload a file > 20Mb, and you max post size is 20M. In addition your upload_max_filesize is 30M. But more importantly, you have 300M specified as memory_limit, yet the error indicates it is set to 32M. Did you restart the web server after making the change to your php.ini ?
        • 8416
        • 173 Posts
        Thanks for the reply. The server restart fixed it smiley