We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 12584
    • 208 Posts
    I have an old MOdx site not touched for over a year was working fine, got a call from the guy who runs it to say he now cant upload, the MOdx version is 9.6.1.p2 and the maxi gallery is whatever was the latest version in June last year.

    I think this is a server issue but I wanted to get some feedback before I ask the server company.

    Here is my parse error after attempting to upload 1 63kb jpeg image.

    MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource: 
    « PHP Parse Error » 
      
    PHP error debug 
      Error:  ini_set() has been disabled for security reasons   
      Error type/ Nr.:  Warning - 2   
      File:  /home/markanto/public_html/assets/snippets/maxigallery/watermark/Thumbnail.class.php   
      Line:  344   
      Line 344 source:  ini_set('memory_limit',$this->memory_limit);    
      
    Parser timing 
      MySQL:  0.0181 s (45 Requests) 
      PHP:  0.0838 s   
      Total:  0.1019 s   
    


    Can anyone offer any advice

    Thanks Ian
      • 1343 ☆ A M B ☆
      • 2,213 Posts
      It looks like your host changed its default php configuration as the error notes:

      ini_set() has been disabled for security reasons


      I suspect that is the problem.
      AMDbuilder
        Patrick | Server Wrangler
        About Me: Website | Tweets |  MODX Hosting
        • 12584
        • 208 Posts
        Yep that was the problem contacted host all perfect now.

        Cheers
          • 1343 ☆ A M B ☆
          • 2,213 Posts
          Glad to hear you got it resolved!
            Patrick | Server Wrangler
            About Me: Website | Tweets |  MODX Hosting