We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 12013
    • 61 Posts
    Thought I would post here, I have been searching and will continue to do so. Basically I get the following parse error when making a snippet call that I have used on multiple other sites. Can someone tell me if this is due to the SQL version or what else might be causing this. Any help will be greatly appreciated

    Thanks

    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource:
    « Execution of a query to the database failed - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ’-ces_maxigallery ( `id` int(10) unsigned NOT NULL auto_increm »
    SQL: CREATE TABLE `cuttiaa`.modx-ces_maxigallery ( `id` int(10) unsigned NOT NULL auto_increment, `gal_id` int(10) unsigned NOT NULL, `filename` tinytext NOT NULL, `title` text NOT NULL, `date` datetime NOT NULL, `descr` text default NULL, `pos` int(10) default NULL, `own_id` int(10) default NULL, `hide` int(1) default 0, PRIMARY KEY (`id`) ) TYPE=MyISAM AUTO_INCREMENT=1 ;
      • 7923
      • 4,213 Posts
      I believe it’s because you have used a dash (-) in table names.. I think that’s a no no. Replace it with underscore (_).


        "He can have a lollipop any time he wants to. That's what it means to be a programmer."