We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 17944
    • 9 Posts
    This is the error I get from the container call or the childgallery call to Maxigallery...
    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource:
    « Execution of a query to the database failed - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-ex_maxigallery ( `id` int(10) unsigned NOT NULL auto_increment, `gal_id' at line 1 »
          SQL: CREATE TABLE `modx-ex`.modx-ex_maxigallery ( `id` int(10) unsigned NOT NULL auto_increment, `gal_id` int(10) unsigned NOT NULL, `filename` tinytext NOT NULL, `title` text NOT NULL, `date` datetime NOT NULL, `descr` text default NULL, `pos` int(10) default NULL, `own_id` int(10) default NULL, `hide` int(1) default 0, PRIMARY KEY (`id`) ) TYPE=MyISAM AUTO_INCREMENT=1 ; 
    


    I’m developing on MAMP - not some strange host server, and I’ve got Maxigallery working on another local MAMP site with Modx.  Oh by the way, this Modx site is THE default Modx install with nothing else added - I’m just begun to add other modules like Maxigallery!

    What can be wrong?
      • 17944
      • 9 Posts
      It’s my problem and I suspect I know what’s wrong.  My mySql tables are prefixed with "modx-ex" and I now see that the error is pointing directly at the hyphen in the prefix!
      ****
      It is confirmed. I’ve installed a new dev site and copied all my changes to the new site and Maxigallery is working. The mySql error must have been caused by using a prefix that contains a "hypen" (for the mySql tables names). Modx otherwise works fine with that type of prefix but not Maxigallery.