We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 17944
    • 9 Posts
    I’m developing my site with Modx 9.6.2 and MG .5.2 on MAMP.

    I seem to have the photo Manager and all the Manager buttons. The upload function seems to work to upload (all but one of any set of photos that I upload - which is good enough for now).  The "Delete all pictures" button usually works too - because when I look in the site’s galleries folder the appropriate id’d childgallery is gone.

    But am I supposed to see the photos in the Manager once I do a re-sync? -- because I don’t.  I can find that the uploaded photos are in the appropriate id’d site gallery folder but nothing shows on the page - whether I’m logged into the site or not.  Of course I’ve made sure the snippet calls are ! not cached -- which seems to solve most problems for many others -- but not for me.  I can’t get any photos to display at all -- the MG calls I’m using are straight from the wiki "Creating your first gallery".

    So I guess it makes sense that if I can’t see photos after re-syncing the MG Manager then it explains why I can’t see any photos on my site? -- but what is the problem?

    Please help!  And thank you in advance!
      • 7923
      • 4,213 Posts
      Hmm.. sounds odd. Have you tried reinstalling the snippet? Also try the v0.6 test version from the sticky topic.


        "He can have a lollipop any time he wants to. That's what it means to be a programmer."
        • 17944
        • 9 Posts
        It’s working now. I have been spending hours in this forum to find the solution and this thread pushed me into the correct solutions: http://modxcms.com/forums/index.php/topic,18808.0.html.

        My foolishness for not knowing enough about how big a photo is a "big" photo for the web. Now I’ve learned and of course now I know ’better’ how to work with proper sizing to post my photos. Also, adjusting the php.ini settings might have helped, too.

        Thanks for your help.
          • 17944
          • 9 Posts
          For other Modx and AMP newbies like myself:

          I would add two other areas that helped me solve the problem -- using MAMP Pro gets me to easily displaying my error logs for PHP and Apache. In this instance, the PHP error log clearly showed that the MaxiGallery Manager upload function was erroring out because of the jpg size that I was asking MG Manager to upload.

          Also, by looking into the Modx management Reports tab under System Info, I could see that the maxigallery database table was empty even though photos appeared in the gallery folders on the site. Obviously, the PHP upload (size) error prevented the process from completing and getting the photos registered into the database?

          I hope this helps others debug similar issues...
            • 7923
            • 4,213 Posts
            Yes, that’s correct and good that you got it solved by your self.. that’s the best way to learn stuff.

            Btw. Have you read the "Important note" part under the "creating your first gallery" tutorial? You are basically having the issue that is described there, but you just don’t get the error messages on browser. The wiki part has some info about settings you can tweak to allow upload of bigger images. And it isn’t just the size of the images, everything that requires php processing, such as dropshadow effects etc, they add to the running time of the script and can ultimately cause problems with "max_execution_time" setting. But go ahead and read that wiki part, I have tried to explain some of the related php / apache settings there.


              "He can have a lollipop any time he wants to. That's what it means to be a programmer."