Any ideas?
« MODx Parse Error »
MODx encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
PHP error debug
Error: mkdir() [function.mkdir]: Unable to access assets/galleries/52/
Error type/ Nr.: Warning - 2
File: /var/www/vhosts/exampledomain.com.au/httpdocs/assets/snippets/maxigallery/maxigallery.php
Line: 313
Line 313 source: if(!mkdir($mg->path_to_gal, 0777)) {
Thanks
Jake
Try the v0.6 test version:
http://modxcms.com/forums/index.php/topic,24600.0.html
There were some bugs that can cause this and I have tried to fix them. Please report back if that version helps.
"He can have a lollipop any time he wants to. That's what it means to be a programmer."
Thanks, Doze. Unfortunately, that didn’t fix it.
Jake
Is it the exactly same error`?
Have you set CHMOD 777 access rights to the /assets/galleries folder?
"He can have a lollipop any time he wants to. That's what it means to be a programmer."
I doubt your server is running with server module PHP (I mean it is not CGI version) and safemode On ?
I do have permissions set correctly on the galleries folder. PHP error debugger is now showing that safe mode is on.
I’m sure that’s the cause of the problem. I asked the host to turn it off a few days ago, so I’ve just sent them a reminder,
I’ll let you know how it works out.
Many thanks
Jake
I personally have never tried, but you may avoid safe mode problem by using &use_ftp_commands and approriate ftp account information with MaxiGallery parameters.
Thanks everyone. Safe mode is now off and the gallery works perfectly.
That’s the new version I’m using, Doze and it seems to be a good one.
Great stuff
Jake