We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 16892
    • 107 Posts
    I have over 2,000 images to upload in 12 different galleries. There’s anywhere between 80-200 images in each gallery.
    I create the document, manually add the first image (so that the folder is created) and then FTP the remaining images to the gallery folder.
    Because of the permissions issue, I manually change ownership and group of all the uploaded files and then I click resynch. If I don’t resynch fails.
    Depending on the number of images, sometimes the resynch process will complete or it will time out. If it times out, I click resynch again, until
    the page refreshes correctly and the success message appears.

    What is happening when a folder is resynched? I’ve looked at the files in the folder and in the db, and I see duplicates. Are the duplicates created when I
    run a resynch more than once? If this is the case, is the only solution to the duplicate issue to increase the memory limit so that the resynch never fails?

    This is my snippet call; I am not using &keep_bigimg:

    [!MaxiGallery? &galleryOuterTpl=`tpl_galleryOuter` &galleryPictureTpl=`tpl_galleryPicture` 
    &js=`scrGalleryJS` &max_pic_size=`580` &quality_thumb=`100` &quality_pic=`100` 
    &max_thumb_size=`190` &order_direction=`ASC` &order_by=`filename`!]
    


    When I try to delete the duplicate images using the maxigallery manager interface, it results in an error. This error also happens when I try to hide or re-sort the images.
    I believe it is permission related; what do I need to do to allow changes to be saved? I don’t mind a manual solution for now, I just need to get these galleries uploaded.
    If I manually delete the reference to the duplicate file(s) in the maxigallery table and delete the images from the directory, will that clean up my display?

    Any help appreciated.

    Thanks.

      • 16892
      • 107 Posts
      Ok. Changing ownership to daemon and permissions on the files to 666 makes maxigallery work (save/sort/resynch), but makes my sysadmin threaten to quit, so that’s not going to work in the long run.

      That aside, when I do set the permissions correctly and resynch the files, I get duplicates. For every file I uploaded, I get two sets of duplicates (original.jpg, 1original.jpg, 11original.jpg), etc.
      Yes, I found the bit of code regarding &keep_bigimg, implemented the code changes and tested the snippet call with the parameter set to 1 and 0 and without the parameter at all. I still get the duplicates.

      Please help.

      Thanks.
        • 7923
        • 4,213 Posts
        Try the v0.6 test version. There was a bug in resynching galleries when &keep_big_img=`1`.

        And yes, it takes alot of memory when doing the resynch operation. Depends on the size of images etc.. Also the script takes alot of time to process the images, so you may hit your server limit for maximum script running time. It’s best to resynch them in smaller batches in that case.

        If the resynching process fails, it could lead up to duplicate files and/or database entries.


          "He can have a lollipop any time he wants to. That's what it means to be a programmer."
          • 16892
          • 107 Posts
          Thing is, I wasn’t using &keep_bigimg at all initially. I did notice that I got duplicates if i did the following: add one image by the manager interface and then add another by ftp. if i resynched the folder after ftp-ing the second image, the ftp-ed image would result in four images--the first set (orig and thumb), then a duplicate set prefixed with "1". This happened whether I changed the bit of code in maxigallery.php or used keep_bigimg on or off.

          I will try 0.6 and see