We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 4310
    • 2,310 Posts
    Have been using v0.41 for sometime, decided to upgrade and when I try to upload JPG images I am now getting...
    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 5120 bytes) in /home/sites/sav.org.uk/public_html/assets/snippets/maxigallery/watermark/Thumbnail.class.php on line 183

    PNG & GIF are O.K. this is on my webhost running PHP 4.4.
    I’ve tried it on PHP 5 and I don’t get the message but the thumbnails aren’t created.
    Is there a way round this or do I stick with the old version?
    Thanks
    David
      • 7923
      • 4,213 Posts
      Hmm.. It seems that the thumbnails script is now using more memory than what’s the allowed limit in your server.. It’s strange though as there has been no change to thumbnails generating code in v0.5 comparing to v0.4.1.. Have you tried small JPG images?

      There is slight change actually though.. Before the thumbnails script always set the memory limit with ini_set() to 10mb or something, I have changed it so that if the limit in the server is already above 10mb, it won’t set it.. but if ini_get() doesn’t work in your environment, it might fail I guess..

      You could ask your server host that can you do your own php.ini and increase the memory limit. I know that currently the image processing scripts take a lot of resources, but this issue will be addressed at some later stage..


        "He can have a lollipop any time he wants to. That's what it means to be a programmer."
        • 31341
        • 15 Posts
        I had the same issue. I backed up the maxigallery table, dropped it, and did a fresh install. Everything seems to be working fine now. It was frustrating me for a while but the problem seems to be solved.


        -Devin