Fixed it.
It turns out that when you install the rpm for gd, it does not modify the php.ini to include the extension. simply adding the following line to php.ini fixed the error:
extension=gd.so
Cheers!
I’m having the same problem (blank page upon uploading). But i’ve got the gd libraries, and it’s listed in the php.ini also. When i look at the galleries folder after uploading only 2 versions of the files are there.so, i really don’t know what to do.