Quote from: codezero at Dec 13, 2006, 03:11 PM
What I had :
PHP Fatal error: Call to undefined function handlePics() in /var/www/html/assets/snippets/maxigallery/maxigallery.php on line 296,PHP Fatal error: Call to undefined function handlePics() in /var/www/html/assets/snippets/maxigallery/maxigallery.php on line 296
I changed the line from:
handlePics($pics_tbl, $path_to_gal, $pageinfo[’id’], $jpgfilename, "jpeg");
$mg->handlePics($pics_tbl, $path_to_gal, $pageinfo[’id’], $jpgfilename, "jpeg");
as well as the PNG line for the same call , as I had noticed the handlePics function is called the same way throughout... So this worked until
Call to undefined function ImageCreateFromJPEG() in /var/www/html/assets/snippets/maxigallery/watermark/Thumbnail.class.php on line 183
For information, the directory is getting created, and one image is extracted, then nothing happens, no manipulation, it dies.
I’ve upped my post size, memory size, and all that stuff pretty high as one of the zip files was 100 megs, but I also dropped it down to a smaller zip file to test it and still had no luck.
It turns out that when you install the rpm for gd, it does not modify the php.ini to include the extension. simply adding the following line to php.ini fixed the error:
extension=gd.so
Cheers!