MODx encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Table 'modx.modx_maxigallery' doesn't exist »
SQL: DESC `modx`.modx_maxigallery$link="<a href=\"index.php?id=" . $picture_target . "&gal_id=".$pageinfo['id']."&pic=" . $pic['id'] . "\">";
$link="<a href=\"[~[*id*]~]?id=" . $picture_target . "&gal_id=".$pageinfo['id']."&pic=" . $pic['id'] . "\">";
You have to create the database table your self with phpmyadmin or something, if the database user you have in modx is not allowed to create tables.
MODx encountered the following error while attempting to parse the requested resource: modx.modx_maxigallery’ doesn’t exist
If you look my post above yours, you see that I started to make the FURL changes to it, but forgot to finish them, I’ll do the necessary changes soon. You can still use the snippet as is in the mean time.
still which - instead of index.php .. we can write also in such a way e.g. [~[*id*]~]:
I had this same error after installing MaxiGallery. My database user has ALL PRIVILEGES, so that cannot be the reason for the error. I created the table manually, and it works fine now, but I thought you should be aware that database user priviliges is not the cause of the error (at least not the only cause).
Quote from: Adam16 at Apr 07, 2006, 06:21 AMYou have to create the database table your self with phpmyadmin or something, if the database user you have in modx is not allowed to create tables.
MODx encountered the following error while attempting to parse the requested resource: modx.modx_maxigallery’ doesn’t exist