Thanks. All I did was mull over the lightbox JavaScript a little bit. It’s well-commented so it wasn’t all that difficult (not nearly as tough as writing the thing must have been).
Nice work ZAP! That will denitely help someone wanting to do the same thing sometime.
About the issue that you are having with the css/js scripts (that they are not allways loaded to the head of the template), I think you should add it to modx bugtracker so we can get it resolved..
And just to be clear, by saying that you guys are having "blank page" do you mean that the picture opens in a blank page or that modx returns a blank page when browsing galleries for example? I’ve seen that you ZAP have battled against the latter problem too..
I think the problem could relate to FS #124. I am currently testing out Wendy’s fix suggested in the bug report - anybody care to try the solution and see if it fixes the problem with MaxiGallery?
About the issue that you are having with the css/js scripts (that they are not allways loaded to the head of the template), I think you should add it to modx bugtracker so we can get it resolved..

Quote from: doze at May 07, 2006, 09:25 AMI think the problem could relate to FS #124. I am currently testing out Wendy’s fix suggested in the bug report - anybody care to try the solution and see if it fixes the problem with MaxiGallery?
About the issue that you are having with the css/js scripts (that they are not allways loaded to the head of the template), I think you should add it to modx bugtracker so we can get it resolved..
Just a thought anyway, it could well be a new problem we need to track down.
Maybe it relates to the problem, but it seems that this bug report is about regclient calls not being processed at all if on an uncached document with uncached snippet call.. but the regclient api functions were patched in the 0.9.2 release, and I also reported that bug at the 0.9.1 known issues thread and atleast wendy did some patch for it.. so that should work now I guess, more talk on this here.
Quote from: doze at May 07, 2006, 09:25 AMI think the problem could relate to FS #124. I am currently testing out Wendy’s fix suggested in the bug report - anybody care to try the solution and see if it fixes the problem with MaxiGallery?
About the issue that you are having with the css/js scripts (that they are not allways loaded to the head of the template), I think you should add it to modx bugtracker so we can get it resolved..
Just a thought anyway, it could well be a new problem we need to track down.
« MODx Parse Error »I don’t understand what is wrong.
MODx encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
PHP error debug
Error: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error:
Error type/ Nr.: Warning - 2
File: /home/function/www/site5/public_html/assets/snippets/maxigallery/watermark/Thumbnail.class.php
Line: 183
Line 183 source: $this->img["src"] = ImageCreateFromJPEG ($imgfile);
Parser timing
MySQL: 0.0080 s s (3 Requests)
PHP: 0.1061 s s
Total: 0.1141 s s
The patch described in FS #124 wasn’t applied in 0.9.2, which means that the problem could be related. Definitely needs further investigation but I think the two issues are linked in some way - I’ll see if I can replicate the intermittent behaviour for MaxiGallery.
Maybe it relates to the problem, but it seems that this bug report is about regclient calls not being processed at all if on an uncached document with uncached snippet call.. but the regclient api functions were patched in the 0.9.2 release, and I also reported that bug at the 0.9.1 known issues thread and atleast wendy did some patch for it.. so that should work now I guess, more talk on this here.
next error:
« MODx Parse Error »I don’t understand what is wrong.
MODx encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
PHP error debug
Error: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error:
Error type/ Nr.: Warning - 2
File: /home/function/www/site5/public_html/assets/snippets/maxigallery/watermark/Thumbnail.class.php
Line: 183
Line 183 source: $this->img["src"] = ImageCreateFromJPEG ($imgfile);
Parser timing
MySQL: 0.0080 s s (3 Requests)
PHP: 0.1061 s s
Total: 0.1141 s s
[!MaxiGallery!]
Я сожалею. I took a year of Russian in college but I’m not going to embarass myself by trying to speak it now. That was a LONG time ago.
russian language..
I don’t want use watermark. That’s why I call the snippet with default settings:
[!MaxiGallery!]
That class in watermark folder is used to create all thumbnails, with or without watermarks. It seems that you don’t have GD library installed on your webserver or the GD library is too old. It has to be versio 1.8 or later.
russian language..
I don’t want use watermark. That’s why I call the snippet with default settings:
[!MaxiGallery!]
This discussion is closed to further replies. Keep calm and carry on.