We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33372
    • 1,611 Posts
    Quote from: doze at May 07, 2006, 09:25 AM

    Nice work ZAP! That will denitely help someone wanting to do the same thing sometime.

    About the issue that you are having with the css/js scripts (that they are not allways loaded to the head of the template), I think you should add it to modx bugtracker so we can get it resolved..

    And just to be clear, by saying that you guys are having "blank page" do you mean that the picture opens in a blank page or that modx returns a blank page when browsing galleries for example? I’ve seen that you ZAP have battled against the latter problem too.. smiley
    Thanks. All I did was mull over the lightbox JavaScript a little bit. It’s well-commented so it wasn’t all that difficult (not nearly as tough as writing the thing must have been).

    I wasn’t getting totally blank pages (like I was in that other thread you mentioned, and interestingly I have not had that happen a single time now that I am running the latest release either). It was just loading the image as if it had been called by a normal link (big image in a blank white page). I’m 99% positive that this was caused by the JavaScript not being added to the header, since every time I was able to check the page source after this ocurred it was not there. Now that I have hard-coded it into my template the issue has never reared its head again. So this is almost definitely an intermittent bug in the parser class of some sort.

    I’m still really in awe of this snippet, btw - DAMN NICE WORK!
      "Things are not what they appear to be; nor are they otherwise." - Buddha

      "Well, gee, Buddha - that wasn't very helpful..." - ZAP

      Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options
      • 10487 MODX Staff
      • 1,535 Posts
      Quote from: doze at May 07, 2006, 09:25 AM

      About the issue that you are having with the css/js scripts (that they are not allways loaded to the head of the template), I think you should add it to modx bugtracker so we can get it resolved..
      I think the problem could relate to FS #124. I am currently testing out Wendy’s fix suggested in the bug report - anybody care to try the solution and see if it fixes the problem with MaxiGallery? smiley

      Just a thought anyway, it could well be a new problem we need to track down.
        Garry Nutting
        Senior Developer
        MODX, LLC

        Email: [email protected]
        Twitter: @garryn
        Web: modx.com
        • 33372
        • 1,611 Posts
        Quote from: garryn at May 07, 2006, 01:22 PM

        Quote from: doze at May 07, 2006, 09:25 AM

        About the issue that you are having with the css/js scripts (that they are not allways loaded to the head of the template), I think you should add it to modx bugtracker so we can get it resolved..
        I think the problem could relate to FS #124. I am currently testing out Wendy’s fix suggested in the bug report - anybody care to try the solution and see if it fixes the problem with MaxiGallery? smiley

        Just a thought anyway, it could well be a new problem we need to track down.


        That does look like it might be related, although it’s not reported as an intermittent bug there. Ya gotta hate those bugs that come and go as they please. They’re the hardest to diagnose.

        I have posted a new bug report here: http://modxcms.com/bugs/task/383

        If anyone has insight into this or if you experiment with possible solutions please let the folks there know.
          "Things are not what they appear to be; nor are they otherwise." - Buddha

          "Well, gee, Buddha - that wasn't very helpful..." - ZAP

          Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options
          • 7923
          • 4,213 Posts
          Quote from: garryn at May 07, 2006, 01:22 PM

          Quote from: doze at May 07, 2006, 09:25 AM

          About the issue that you are having with the css/js scripts (that they are not allways loaded to the head of the template), I think you should add it to modx bugtracker so we can get it resolved..
          I think the problem could relate to FS #124. I am currently testing out Wendy’s fix suggested in the bug report - anybody care to try the solution and see if it fixes the problem with MaxiGallery? smiley

          Just a thought anyway, it could well be a new problem we need to track down.

          Maybe it relates to the problem, but it seems that this bug report is about regclient calls not being processed at all if on an uncached document with uncached snippet call.. but the regclient api functions were patched in the 0.9.2 release, and I also reported that bug at the 0.9.1 known issues thread and atleast wendy did some patch for it.. so that should work now I guess, more talk on this here.

          But now it seems that there is still some bug somewhere around that causes the regclient functions to fail randomly.. I know that the api fuctions checks that if the scripts are allready included to the head through regclient api, it won’t include them twice.. so maybe there’s some bug what makes the functions to think that the scripts are allready included where they are not.. or something like that..


            "He can have a lollipop any time he wants to. That's what it means to be a programmer."
            • 24166
            • 11 Posts
            next error:
            « MODx Parse Error »
            MODx encountered the following error while attempting to parse the requested resource:
            « PHP Parse Error »

            PHP error debug
            Error: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error:
            Error type/ Nr.: Warning - 2
            File: /home/function/www/site5/public_html/assets/snippets/maxigallery/watermark/Thumbnail.class.php
            Line: 183
            Line 183 source: $this->img["src"] = ImageCreateFromJPEG ($imgfile);

            Parser timing
            MySQL: 0.0080 s s (3 Requests)
            PHP: 0.1061 s s
            Total: 0.1141 s s
            I don’t understand what is wrong.
              • 10487 MODX Staff
              • 1,535 Posts
              Quote from: doze at May 07, 2006, 01:41 PM

              Maybe it relates to the problem, but it seems that this bug report is about regclient calls not being processed at all if on an uncached document with uncached snippet call.. but the regclient api functions were patched in the 0.9.2 release, and I also reported that bug at the 0.9.1 known issues thread and atleast wendy did some patch for it.. so that should work now I guess, more talk on this here.
              The patch described in FS #124 wasn’t applied in 0.9.2, which means that the problem could be related. Definitely needs further investigation but I think the two issues are linked in some way - I’ll see if I can replicate the intermittent behaviour for MaxiGallery.
                Garry Nutting
                Senior Developer
                MODX, LLC

                Email: [email protected]
                Twitter: @garryn
                Web: modx.com
                • 33372
                • 1,611 Posts
                Quote from: qnick at May 07, 2006, 01:49 PM

                next error:
                « MODx Parse Error »
                MODx encountered the following error while attempting to parse the requested resource:
                « PHP Parse Error »

                PHP error debug
                Error: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error:
                Error type/ Nr.: Warning - 2
                File: /home/function/www/site5/public_html/assets/snippets/maxigallery/watermark/Thumbnail.class.php
                Line: 183
                Line 183 source: $this->img["src"] = ImageCreateFromJPEG ($imgfile);

                Parser timing
                MySQL: 0.0080 s s (3 Requests)
                PHP: 0.1061 s s
                Total: 0.1141 s s
                I don’t understand what is wrong.

                Have you tried calling the snippet without a watermark? It looks as if the snippet is not finding your watermark image, and that’s why you’re getting this error. Try it without the watermark, and if that works then check that your watermark image is where it should be before you try adding it again.

                What is your first language (maybe we can answer you in that)?
                  "Things are not what they appear to be; nor are they otherwise." - Buddha

                  "Well, gee, Buddha - that wasn't very helpful..." - ZAP

                  Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options
                  • 24166
                  • 11 Posts
                  russian language..

                  I don’t want use watermark. That’s why I call the snippet with default settings:
                  [!MaxiGallery!]
                    • 33372
                    • 1,611 Posts
                    Quote from: qnick at May 07, 2006, 02:13 PM

                    russian language..

                    I don’t want use watermark. That’s why I call the snippet with default settings:
                    [!MaxiGallery!]

                    Я сожалею. I took a year of Russian in college but I’m not going to embarass myself by trying to speak it now. That was a LONG time ago.

                    Do you have the GD library installed on your server?
                      "Things are not what they appear to be; nor are they otherwise." - Buddha

                      "Well, gee, Buddha - that wasn't very helpful..." - ZAP

                      Useful MODx links: documentation | wiki | forum guidelines | bugs & requests | info you should include with your post | commercial support options
                      • 7923
                      • 4,213 Posts
                      Quote from: qnick at May 07, 2006, 02:13 PM

                      russian language..

                      I don’t want use watermark. That’s why I call the snippet with default settings:
                      [!MaxiGallery!]

                      That class in watermark folder is used to create all thumbnails, with or without watermarks. It seems that you don’t have GD library installed on your webserver or the GD library is too old. It has to be versio 1.8 or later.

                      You can check what version you have by looking at the phpinfo() at modx manager. Go to administration > view system info and click view at the phpinfo block.


                        "He can have a lollipop any time he wants to. That's what it means to be a programmer."

                      This discussion is closed to further replies. Keep calm and carry on.