We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 16194
    • 103 Posts
    Hi Modxers!

    I moved my site from my local server to a web server now and everything works except the SMF brigde. When I try to synchronize users it gives out the following:

    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource:
    « Execution of a query to the database failed - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ’-forum.smf_settings (variable,value) VALUES(’integrate_pre_include’,’/is/htdocs/’ at line 1 »
    SQL: REPLACE INTO db100-forum.smf_settings (variable,value) VALUES(’integrate_pre_include’,’/is/htdocs/**here goes my secret path **/assets/modules/smforum/smf.integrate.inc.php’);

    Take a look at the red text, it says "-forum". The whole name of the db is however db100-forum.

    I have encountered this problem before, on my local machine. There I could change the database name (removing the "-") and then it suddenly worked. Now I’m on dedicated webspace and I cannot change the database name.

    MySQL 4.1.15-Debian, PHP 5 latest update and ModX 0.95

    Any ideas what is going wrong there? undecided

    Your help is desperately needed!

      Impossible is nothing - with ModX
      • 16194
      • 103 Posts
      I think I found a solution (at least it worked for me).

      In smf.base.class.inc.php backticks need to be added to db_name like this:

      	// get smf table name
      	function getFullTableName($tbl) {
      		return $this->smfSettings['`db_name`'].".".$this->smfSettings['db_prefix'].$tbl;
        Impossible is nothing - with ModX
        • 23571
        • 223 Posts
        Thanks. This was the resolution for my problem this afternoon.