We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 17058
    • 80 Posts
    again again,

    the f-flag-problem is solved. to get the module to send mails i have to set the phpmail f-flag.

    replaced the code in assets/modules/txnewsletters/txnewsletters.inc.php in line 1536 from
    $result=mail('', $subject,'', $headers);

    to
    $result=mail('', $subject,'', $headers,'-f [email protected]');


    I placed the {link_unsubscribe} placeholder in the newsletter-template. By using this link from the mail im able to unsubribe from the newsletterlist. But whats about a manual unsubribing form provided from the snippet. Like mentioned in the posts above i’ve got a document only for unsubscribing and used the [!TXNewsletters!] call. Nada, Niente.
    I’ve installed the module in an other MODX-installation. the call dont work here, too. Am i wrong?

    A last question: I want to provide a link to the newsletterdocument online (if a mailprovider screw up the html-mail).
    <a href="[~[+id+]~]">Link to newsletter online</a>

    This code dont work. Whats the right link?

    Thanks, le block
      le_block is Member of FUTY | Medienagentur aus Leipzig mit Schwerpunkt Marketing, Branding, Print und Webdesign
      • 791
      • 46 Posts
      I have installed TXNewsletters on a second website - first time it worked a treat, however this time I have a Parse error as follows:

      [tt]Parse error: syntax error, unexpected $end, expecting ’,’ or ’;’ in /var/www/vhosts/hangar8.co.uk/httpdocs/manager/includes/document.parser.class.inc.php(769) : eval()’d code on line 109[/tt]

      I have Googled for a solution and I can’t find out why this is happening. Does anyone have any ideas? What other info do I need to provide to help get to the bottom of this?


      OK, sorted. My error - I had inserted a rogue / into domxml-php4-to-php5.php while trouble-shooting. All fingers and thumbs, clearly. embarrassed
        Learning a little more each day.
        • 14617
        • 47 Posts
        Hi all

        I was getting:
        Warning: mail(): Bad parameters to mail() function, mail not sent. in /hsphere/local/home/subvisio/subvision.dk/kunder/ejlskov/assets/modules/txnewsletters/txnewsletters.inc.php on line 1536 Error during sending !
        Some newsletters have not been sent correctly.


        I fixed this by changing line 1534 from:
        $headers .= $send_html . "\n";
              
        $result=mail('', $subject, '', $headers);
        

        To:
        //$headers .= $send_html . "\n";
              
        $result=mail('', $subject, $send_html, $headers);


        I mean: comment out the html in header and put it straigt in the mail function call.

        This solved my mail sending problems.

        Hope this helps somebody
        Jonas
          • 29525
          • 388 Posts

          I’m just trying out TXNewsletters.

          Finished installation. First thing I tried was to subscribe. Got this error:

          Fatal error: Call to undefined function checkdnsrr() in C:\wamp\www\assets\modules\txnewsletters\txnewsletters.inc.php on line 1290


          I see others have encountered this, but did I miss it or is there fix for this?

          I’m working on wamp server
          winxp
          modx 9.6.2
          apache 2.2.8
          php 5.2.6

          Thank you!
            www.terrybarthdesign.com
            • 29525
            • 388 Posts

            Anyone?
              www.terrybarthdesign.com
              • 6433
              • 25 Posts
              **UPDATED:
              Read through the posts one more time and found the url_open bug spoken about early on. I guess this all depends on your version of php, but the only way for me to track it was to trawl through the source code to track the stoppage.

              +++++++++++++++++++++++++++

              I’m having a strange problem with TX as well - I’ve installed following the steps, and all looks great. Only problem is it seems to send out blank emails. I’ve tried sending and ’downloading’ the newsletter, but both are completely blank  - no headers - nothing.

              Is there a setting I’m missing? I’m on 0.9.6.2 if that means anything. Obviously the email ’send’ part is working fine, and I can add members to the subscription list ok, just can’t seem to get anything out. Would love any help.

              Cheers,
              Dan
                • 36549
                • 572 Posts
                I’m having trouble at section number 4.
                I’ve swapped the mutate_module_resources.dynamic.php for the one suggested in an earlier post but now i get this message when i try to save the module:

                You don't have permission to access /modx096/manager/index.php on this server.
                
                Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


                Can anyone offer any help with this?

                Thanks
                  www.9thwave.co.uk
                     WEB | DESIGN | PRINT
                  • 36549
                  • 572 Posts
                  Really sorry to bump this but i’m still having probelms.
                  I’ve just started from scratch and re-installed Modx.
                  I upload the TXnewsletter module directory to assets/modules and create a directory named upload to assets/
                  I then create the snippet and then the module.
                  It’s when i get to the module that i seem to have a problem...
                  To start with i only have a ’configuration’ tab and not a ’dependencies’ tab. So i enter the information into the dependencies area and when i click on save i get a 404 error. I’ve attached a screenshot to demonstrate.

                  I really can’t see what i’m doing wrong, maybe it’s a system configuration issue?...any suggestions?
                    www.9thwave.co.uk
                       WEB | DESIGN | PRINT
                    • 29525
                    • 388 Posts
                    I’m having trouble with images showing up in emails sent from TXNewsletter.

                    I’m using a complete URL for the logo image in the template for the non variable part of the newsletter.

                    For the editable area (document content) TinyMCE configuration has path options set to fullpath url.

                    Here’s what’s happening.

                    In the mail sent to my Eudora mail client, the logo (full path image) appears just fine, but the images entered via TinyMCE do not (only the relative path is included in the email).

                    In my Lotus Notes client, the logo does not appear, but the images entered in TinyMCI do appear.

                    Finally, when I am using TinyMCE to create the content and I select an image, it is not visible in the image dialogue preview and does not appear in the document content area of TinyMCE even though I can see a relative path in the HTML viewer of TinyMCE.

                    Not sure what to do next. Ideas?

                    Thank you!

                    Terry
                      www.terrybarthdesign.com
                      • 14553
                      • 40 Posts
                      Hello,

                      I’ve posted this message on the french forum but no answer....

                      During setting up of TXNewsletters, on step 4, we need to add dependancies to the snippet in the module.

                      - in module dependencies tab, add " TXNewsletters " snippet dependancy to share params with

                      When I go to the "dependances", and I see no dependancy, I click on the button "dependance management" to add one, as asked. But I get this


                      Vous pouvez ici ajouter ou supprimer les ressources dont dépend ce module. Pour ajouter une nouvelle ressource, cliquez sur l’un des boutons ci-dessous.
                      (in English: you can add here or delete the ressources linked to the module. To add a new ressource, click on the button above)

                      « MODx Parse Error »
                      MODx encountered the following error while attempting to parse the requested resource:
                      « Execution of a query to the database failed - Table ’provconf.smd’ doesn’t exist »
                      SQL: SELECT smd.id,COALESCE(ss.name,st.templatename,sv.name,sc.name,sp.name,sd.pagetitle) as ’name’,CASE smd.type WHEN 10 THEN ’Chunk’ WHEN 20 THEN ’Document’ WHEN 30 THEN ’Plugin’ WHEN 40 THEN ’Snippet’ WHEN 50 THEN ’Template’ WHEN 60 THEN ’TV’ END as ’type’ FROM smd LEFT JOIN `provconf`.`provconf_site_htmlsnippets` sc ON sc.id = smd.resource AND smd.type = ’10’ LEFT JOIN `provconf`.`provconf_site_content` sd ON sd.id = smd.resource AND smd.type = ’20’ LEFT JOIN `provconf`.`provconf_site_plugins` sp ON sp.id = smd.resource AND smd.type = ’30’ LEFT JOIN `provconf`.`provconf_site_snippets` ss ON ss.id = smd.resource AND smd.type = ’40’ LEFT JOIN `provconf`.`provconf_site_templates` st ON st.id = smd.resource AND smd.type = ’50’ LEFT JOIN `provconf`.`provconf_site_tmplvars` sv ON sv.id = smd.resource AND smd.type = ’60’ WHERE smd.module=3 ORDER BY smd.type,name
                      [Copy SQL to ClipBoard]




                      And of course, impossible to add something.
                      Any idea ?

                      Thanks

                      John Steed