Hello,
I’m a newbie here on Modx 1.03 - I have been trying to get Ajaxsearch 1.90 installed, but I get an error - this is happening with Modx 1.02 so I am sure its a permission error of some kind on my host - or is it?
Forbidden
You don’t have permission to access /manager/index.php on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Any suggestions? This is a fresh install of Modx 1.03 and it went fine without any problems.
Thank you in advance for any help.
Samuel
Hi Samuel,
How did you install AjaxSearch190 and when did you get this error ? when searching something ?
Hi,
Thank you for replying.
I simply uploaded the folder for Ajaxsearch into the snippet folder where I’m hosting - and then I made a few changes in three files per the wiki so that I could have it along side of Ajaxsearch 1.85.
Whenever I tried to add the snippet in ModX for 1.90, I would get this error:
Forbidden
You don’t have permission to access /manager/index.php on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
I am going to assume that it is some permission problem - but I think I resolved by removing 1.85 and added 1.90 to the 1.03 build and did a new install. Not the right way I guess, but it seemed to have worked.
I can create snippets in Modx - but for some reason, when I try adding a snippet for 1.90 (it is writing something to index.php?) and that’s when I get the error.
Thanks.
Samuel
If you would like install AjaxSearch 1.9.0 along side the version 1.8.5 provided with MODx 1.0.3 do as follow:
1/ install MODx 1.0.3. This will install ajaxSearch. The installed version of AS is 1.8.5
2/ download AjaxSearch 1.9.0 from the ajaxSearch demo site. Unzip the file in a temporary directory /tmp
3/ rename the /tmp/ajaxSearch as /tmp/ajaxSearch190
4/ Change the default paths in some files:
4.1. change the definition of AS_SPATH in the ajaxSearch190/snippet.ajaxSearch.txt
// Path where ajaxSearch is installed
define(’AS_SPATH’, ’assets/snippets/ajaxSearch190/’);
4.2. change the definition of AS_SPATH in ajaxSearchPopup.php
define (’AS_SPATH’ , ’assets/snippets/ajaxSearch190/’);
4.3. if you use the default release of mootools, in the js/ajaxSearch1/ajaxSearch.js file
change the _base value:
var _base = ’assets/snippets/ajaxSearch190/’;
Change this _base value in the js/ajaxSearch1/ajaxSearch-mootools2.js if you use mootools 1.2
Change this _base value in the js/ajaxSearch1/ajaxSearch-jquery.js if you use jquery
4.4. change the _base value in the js/comment/ajaxSearchCmt.js file
5/ Copy the directory ajaxSearch190 in the assets/snippets direct, just beside the ajaxSearch directory provided by MODx 1.0.3
6/ Open the manager and create a new snippet by duplicating of the existing AjaxSearch snippet, call it AjaxSearch190 and copy/paste in the code window the content of the file assets/snippets/ajaxSearch190/snippet.ajaxSearch.txt
7/ and finally in your MODx documents or templates, use [!AjaxSearch190!] to call the ajaxSearch 1.9.0 release.
This procedure allow you to have two versions of ajaxSearch simultaneously. [!AjaxSearch!] as 1.8.5 and [!AjaxSearch190!] as 1.9.0
I am not sure that it works if you use the ajax mode with two release of ajaxSearch on the same document, but it will run with the non ajaxSearch mode (&ajaxSearch=`0`).
Thank you for the reply - I’ll give it another try...