We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 6573
    • 28 Posts
    Hey Everyone,

    I’ve got a bit of a pickle. Basically I have an few eForms setup that have worked perfectly until the other day. Now suddenly they have started to refuse to send emails to address’s at the sites domain. However if I change the send to address to my email address which is on a different domain everything works fine. My first thought was that the emails on the original domain were broken but that theory doesn’t work because I can still send emails to them and they receive them. So any ideas?

    Thanks,
    Michael
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Is the domain of your email address that still works is on the same host as your site with the scripts?
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 6573
        • 28 Posts
        No
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          I asked, because often hosting will disable the php mail() function from sending to any other server than itself; so usually having email go to your site’s default email will work (or to your personal email if it’s on the same server as your site), while sending to others outside the server won’t.

          That was my best shot...

          Well, actually, I ran across something that might well make this fail just yesterday. It seems both servers are configured to practice "greylisting". On top of this server2 immediately sends back to server1 to validate the email address of the sender. Now when server2 sends the validation enquiry to server1, server1, as part of its greylisting policy, returns a "mailbox busy, try again later" error message. Server2 is looking for a "user ok" message, and aborts with a "bad user validation" error. So server1 and server2 can never exchange mail.
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 6573
            • 28 Posts
            ok thanks for trying, looks like it is doing the opposite of what’s expected then
              • 16885
              • 255 Posts
              I’ve been facing similar issues; I’ve got my domain hosted on a webhost, whereas the mail is hosted by Google Apps, for some reason I can’t send any mail from my webhost to the GA domain (which is the same), however, when I send to a separate Gmail account it works without a delay or other trouble. Odd, to say the least wink
                • 6573
                • 28 Posts
                I found the problem, turns out they installed some junk mail filtering software which they didn’t bother to mention. What a waste of 4 hours