We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 8471
    • 333 Posts
    Hi, I can’t find where I can set the upload limit for a file form.
    Thanks
      Sorry for my bad English grin
      • 25663 MODX Staff
      • 12,272 Posts
      FYI, with PHP file uploads a file-size limit cannot be determined until after a file has been already transferred to the server. The reason is that PHP doesn’t have local access to your filesystem to read the details, even including file extensions/file-types. I’m not sure if eForm post-processes uploads to see if they exceed the file limits or file types (don’t recall, anyway).
        Ryan Thrash, MODX Co-Founder
        Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
        • 8471
        • 333 Posts
        I was asking for it because I have received the error message (from eform)
        namefile has exceeded maximum upload limit.
          Sorry for my bad English grin
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          eForm is merely responding to an upload error condition.

          http://www.php.net/manual/en/features.file-upload.errors.php

          The user comments are well worth reading here

          http://www.php.net/manual/en/features.file-upload.php
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
            • 8471
            • 333 Posts
            Thanks a lot, I’have changed my settings in php.ini and now I received this error message from modx
            Fatal error: Allowed memory size of 52428800 bytes exhausted (tried to allocate 22839916 bytes) in /var/www/manager/includes/controls/class.phpmailer.php on line 1114
            huh
              Sorry for my bad English grin
              • 8471
              • 333 Posts
              I have changed the memory_limit in the php.ini and now I don’t receive the Fatal error, but I received this:
              Main mail: Mailer was unable to send mailCould not instantiate mail function.
              huh huh
                Sorry for my bad English grin