-
☆ A M B ☆
- 24,524 Posts
In the first place, you need to go into your site’s Configuration and change the site’s default email. It’s in the User tab; the seventh item.
To make eForm use a different reply-to address, use the &from parameter. By default the "from" field will use the default email for your site, as configured in the above mentioned configuration option.
-
☆ A M B ☆
- 24,524 Posts
As far as I know, the mailed-by field is exactly what it says, and is supposed to indicate the actual server it came from. I don’t think there is much you can do about that, unless you want to learn how to "spoof" these like spammers do. I see from a quick Google search that others have had similar questions in reference to their gmail.
-
☆ A M B ☆
- 24,524 Posts
Well, if it’s any consolation, mail sent from my server (a VPS in the UK) certain people don’t receive; for example, gmail and hotmail get it OK but Yahoo mail doesn’t. My aunt in Colorado didn’t; she complained to her ISP and they did something and she started getting it.
According to the forums for the hosting company I have my VPS with, Yahoo and other servers "greylist" email; any unknown email is rejected, and only after it gets resent by the originating server will they accept it. Apparently Yahoo and some other servers are not configured very well, and can keep rejecting the mail, or it won’t get accepted for hours. This can also depend on how the originating server is configured to handle rejection.