Subscribe: RSS
  • Hi, i have a very weird problem that I’ve never encountered before.

    Using MODx 0.9.6.2 (an older install) and the TinyMCE + mpuck versions that came wit it, i can use QuickEdit to upload and manage images in the assets/images directory and files in the assets/files directory.

    PROBLEM: if I create any sub-directories, like assets/images/events or assets/files/pdf from the file manager, and then try to upload anything in them, i get the "failed to upload file. internal error..."

    I checked the permissions they’re all 0777, and I’ve checked the resource browser paths, they’re all set as in the DOCUMENT_ROOT setting in php.ini.

    How come I can upload in the main resource directories but not in any of their sub-directories?
    I’ve searched around but can’t find anything relevant.
    Can anybody please help me solve this?

    • Update: problem persists after I upgraded to modx Evolution 1.0. Only thing I kept were the database tables, I basically replaced the whole install (deleted 9.6.2 then installed 1.0 and copied over the template and page content).

      What gives?? Some people are getting a really bad impression of MODx because of this nasty little bug. Please, can’t anybody help?
      • Hi,

        I also have the same problem. Using Modx. 1.0.2 !! I can see the directory, but can not upload image to that directory.
        Any tips ?

        Thanks.
        - pedma -
        • MacLonghorn Reply #4, 9 years ago
          I had this problem with 09x as well, so it’s nothing new. I upgraded to Evo hoping there would be new code to fix it, but didn’t work. Mostly happens when there are a lot of images I think.
            Mark Macatee
            President
            Power 10 Solutions
            http://www.power10solutions.com
          • I have the same problem, the funny thing is that i used the same version of modx 1.0.2 on an other server (same host, same linux,php,mysql) and there all works fine.

            searching the web for 2 days now without finding a solution.

            I tried to install ModX Revolution first von this server, can it be that that’s the problem?
            • Try to disable safe_mode
              • I’m having the same problem. What’s frustrating is that I have two other modx sites running on the same server-- they both upload images just fine, so why the heck isn’t it working on this one??? File permissions are 777, safe_mode is false. Anyone got a clue? I need to get images on this puppy asap. undecided
                • Try editing that user’s ’uploadable image/file/flash/file types’, either by checking the ’Use System Configuration Setting’ or entering specific file extensions.

                  Go to Security -> Manage Users -> [select the specific user] -> User (subtab). Scroll down and edit all four ’uploadable types’.

                  I had this same symptom: one administrator could upload images, but the other couldn’t. Apparently those ’uploadable types’ weren’t automatically set to ’use system setting’ when the user was created.

                  Hope this helps for you.
                  • my host changed the website to another server and the problem was solved.

                    never asked the host what the problem was as i was happy with the result.
                    • I’m not sure if my problem was exactly the same as the other posters here but during my searches I kept coming across this thread which doesn’t really have a solution, so I’m posting this in the hope that it might help someone else out. I solved mine simply by recreating the asset directory structure within the subdirectory.

                      After literally hours of searching and despair I decided to actually read the notes for "File base path" in the manager, and it says:

                      NOTE: The File Browser directory must contain the subfolders images, files, flash and media in order for the file browser to function correctly.

                      So now my folder structure looks something like:

                      root
                      assets
                      images
                      mysubdirectory
                      images
                      myimage.jpg
                      files
                      flash
                      media

                      files
                      flash
                      media
                      etc...

                      manager

                      Now my manager users can upload and insert images and only ever see what’s in their own folder and now TinyMCE is happy, although I also had to make sure the maximum upload size was set large enough.

                      I’m no PHP guru, so if any MODx pros here can see a downside (esp security wise) to this method could you PLEASE TELL ME. undecided