New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Hi

    I transferred my site from one host to another. After this, when try to insert image in TinyMCE editor [open document -> edit -> insert image button -> browse button ] the FCK editor shows only the folders in /assets/images. No images are displaying. There are many images in these folders and in root directory[/assset/images/].

    Also, I can’t upload images. It shows ’Disallowed type’ error.

    When I tried to upgrade it, I got a lot of errors and it made more problem.

    File manager path, Resource Path are changed to new one.

    FCKeditor v2.3.2
    ModX version 2.0 [ it shows 2.0, but actually it is very older version. Older than 0.9.6.1]

    How can I solve this issue?

    ps. any support team can help, I’ll send you the details.

    Pls help ....
    Jurdy

    • Well, i’m gonna join you in this post as i have almost the same problem.
      I can’t see any image or folder in de FCK editor (using modx 1.0.2) but the funny thing is that i can create a new folder but it’s not showing it,still i can see it in my ftp program and modx file manager.


      I tried almost all tips found on this forum but no joy.

      I hope someone can help us here?

      thanks
      migiel
      • Now that you’re with a different host, did you make the necessary changes to the file paths within Tools/Configuration?

        @Migiel: don’t know if this could be part of your problem, but if you already have tried everything you found on here you probably don’t have any issues with file paths or write permissions. I just spent the entire afternoon trying to figure out why thumbnails were appearing in some folders but not others, tearing my hair out, until I finally realised that FCKEditor doesn’t seem to like any letters with accents in my file names. The minute a file ends up in a folder with an accent it doesn’t display any of the files in that folder at all. As I had been uploading files with English as well as Irish names, some folders included files with Irish accented letters. As soon as I replaced these characters with standard characters everything displayed perfectly. Hadn’t come across this before.
        • I’ve been having similar problems in both 0.9.6 and now in Evolution 1.0.3 (yes, I need to upgrade to 1.0.4), and I’ve just found something out that might help.

          When I login as a web user and try to use FCKeditor to view the folder structure/upload a file/link to an existing file, all I see is the top-level folder.

          However, the folder structure and all the files are visible (and available for linking, uploading, deleting, renaming etc.) when I open a new tab in my browser and login to the MODx manager with a different login.

          So, I can only presume from this that FCKeditor is requiring more access than the standard web login provides, but this doesn’t make sense. Yet my directory access is set to 755 so surely that should cover it for at least viewing the files and folders available.

          Does that help anyone (or me?)
          • Hi guys,

            The very strange thing is that the problem solved it selves by migrating to another server. So i think not all of the servers of my host support Modx or just not the whole package.

            I hope this answer helps out others suffering the same problem.

            cheers
            migiel
            • seems like empty user_settings are overwriting upload_files which make AllowedExtensions to be an empty string. please test: https://github.com/eerne/evolution/commit/1a25bade0b5a55c80baafaf9f193e8f82e171d29
              • There is also a Configuration setting to allow front-end users to use the file browser or not.
                  Studying MODX in the desert - http://sottwell.com
                  Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                  Join the Slack Community - http://modx.org
                • In my case after upgrading to 1.0.4, no more images were displayed, only folders. After digging through the mcpuk ajax and connectors, i found that AllowedExtensions was overwritten by user_settings.inc.php and the sql to only get settings that are not en empty space seemed obvious and working (also the code was there already in comment).

                  This issue never happen here (same hosting different server). not sure why. this was quite old going from 0.9.6.1p -> 1.0.4
                  • I had the same prob,

                    I ve checked the
                    manager users > click to edit user > User (tab)
                    > Uploadable Image Types (check "Use System Configuration Setting")
                    > Uploadable Media Types (check "Use System Configuration Setting")
                    > Uploadable Flash Types (check "Use System Configuration Setting")
                    > Uploadable File Types (check "Use System Configuration Setting")

                    worked for me!
                    I hope it helps
                    • Try checking "reset" button under Tools > Configuration > Interface & Features > File base path. That fixed the problem for me.