Subscribe: RSS
  • Hi all,
    I too, like many others it seems, am having difficult with the FCKEditor Resource Manager. I’ve trawled through all the other posts but have yet to find an answer. Here’s the issue:

    I’m using Modx v1.0.0 straight out of the box. The Resource Browser opens but displays no directory structure or file contents and won’t allow me to create folders or upload images.

    The only errors I get are the following Javascript errors, which differ in each browser (FF and IE):

    Firefix:
    Error: this.DOMDocument is null
    Source File: http://www.thewholeworldwindow.com/manager/media/browser/mcpuk/js/fckxml.js
    Line: 108

    IE8:
    Message: Object required
    Line: 159
    Char: 2
    Code: 0
    URI: http://www.thewholeworldwindow.com/manager/media/browser/mcpuk/frmfolders.html

    I would have thought this an directory path issue but for the life of me I’ve checked these and they ’seem’ correct. I can also upload files via Modx’ File Manager with no problems at all.

    I’ve also tried re-installing - thinking a bad install was the cause but I still get the same.

    I have the same modx version installed locally using WAMP Server 2 and that’s working fine (Apache 2.2.11, PHP 5.2.8, MYSQL 5.1.30) so it doesn’t seem to like my hosting setup which is running Linux. Apache 2.2.11, PHP 5.2.10, MYSQL 5.0.81.

    Could the older php version be the cause?

    Can anyone please help before I loose all my hair.

    Cheers guys!
    • Hello,
      Did you upload an image with foreign characters in its name? Have a look here >> http://modxcms.com/forums/index.php/topic,39380.0.html
      • yeah I’ve seen that thread already but no, I get this problem right from the off following a fresh install so at that stage nothings been uploaded at all. As for the uploads that I have done - via modx’ own file manager - they’re just alpha-numeric with underscores.
        • Hey tonec,
          Did you ever resolve this problem? I’ve spent two days on the web looking for an answer that sounds remarkably similar to yours.