We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 16601
    • 13 Posts
    I upload pictures and i see them in the folder window, but now all the pictures are not display. I now that the picture exist, but i cant see them. I have the permission, and i Upload new picture successufully, but also that picture i can’t see.

    What can i do?
    • I just had another site working fine otherwise, but the resource browser did not work. The Manager file manager worked fine, and FTP was also fine.

      I made sure the path and URL in the configuration were correct.

      I upgraded to the latest available TinyMCE plugin.

      Finally, I re-uploaded the manager/media/browser folder, and then it began to work. I presume that one of the many little files in the resource browser’s directory got corrupted during the original site upload.

      If you are using Firefox, you can check the browser’s Error console (in the browser’s Tools menu) if you don’t have Firebug installed. It may give you a clue, as may the MODx event log (in the Reports menu).
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 16601
        • 13 Posts

        I used FF debuger and saw that the problem was that the user upload files with hebrew uncoding, i removed those files and the problem solved.
          • 18206
          • 59 Posts
          This deserves a good bump. I ran into the exact same problem, scratched my head for a good hour and finally checked the error console.
          It turns out foreign characters (å ä ö in my case) gets scrambled on upload and causes a bug. Uploading files with non ASCII7 characters to web servers seem to be a bad idea in general, but since it seems to be a fairly common "mistake", maybe some automatic character replacement would be in order.