I’m getting this error when I try to upload images. The permissions on assets/images/ are set to 777.
I’m also unable to view any images already uploaded into the folder.
-
☆ A M B ☆
- 24,524 Posts
Would you please post how you solved your problem? Many others have the same problem, although it can have any number of causes.
It was as simple as a space before the resource path.
Quote from: kittie at Jul 06, 2009, 01:56 AM
It was as simple as a space before the resource path.
Thanks, it solved my problem with uploading. I also found this post "
Upload Feature Inhibited Error When Adding Files or Images in ModX". Might be helpful for others if they wanted step-by-step guide.
An aspiring web designer & front-end web developer who is very much interested on the modern web.
www.andrewabogado.com
I had similar problem.
Have a webhost in which if I set the WRONG path in File Manager Path it will work, and only then.
Though I cant get sub directories to work.
Tried every solution on this site, to no avail.
My dir under images was getting 0755 which didn´t work, so I tried with 0777, and it didn´t work either.
Any suggestions?
Cheers
Amrit
I know i’m dredging up an old thread, but if anyone else has this problem it is also caused if the file you are uploading is too large.
I had the same problem and found the solution.
The main problem is your resource path.
Go to Reports -> System Info
Find MODX_BASE_PATH there and copy the value (except for the last slash, you can remove it afterwards too)
Go to Tools -> Configuration -> Interface & Features
Find "File base path" there, it will probably be /assets/
Copy the value of the MODX_BASE_PATH there in front of /assets/ so you get something like /your/modx/base/path/assets/
Watch out that you don’t get a double slash with copying the MODX_BASE_PATH.
And of course, save.
If the problem remains, make sure that folders have proper rights (Check out the link posted before by Andrew Abogado)
Hope it helps
Greetings, Kenny