On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I’m getting this error when I try to upload images. The permissions on assets/images/ are set to 777.

    I’m also unable to view any images already uploaded into the folder.
    • Would you please post how you solved your problem? Many others have the same problem, although it can have any number of causes.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
      • It was as simple as a space before the resource path.
        • Quote from: kittie at Jul 06, 2009, 06:56 AM

          It was as simple as a space before the resource path.

          Thanks, it solved my problem with uploading. I also found this post "Upload Feature Inhibited Error When Adding Files or Images in ModX". Might be helpful for others if they wanted step-by-step guide.
            An aspiring web designer & front-end web developer who is very much interested on the modern web.

            www.andrewabogado.com
          • I had similar problem.
            Have a webhost in which if I set the WRONG path in File Manager Path it will work, and only then.
            Though I cant get sub directories to work.

            Tried every solution on this site, to no avail.

            My dir under images was getting 0755 which didn´t work, so I tried with 0777, and it didn´t work either.

            Any suggestions?

            Cheers
            Amrit
            • I know i’m dredging up an old thread, but if anyone else has this problem it is also caused if the file you are uploading is too large.
              • I had the same problem and found the solution.

                The main problem is your resource path.

                Go to Reports -> System Info
                Find MODX_BASE_PATH there and copy the value (except for the last slash, you can remove it afterwards too)

                Go to Tools -> Configuration -> Interface & Features
                Find "File base path" there, it will probably be /assets/
                Copy the value of the MODX_BASE_PATH there in front of /assets/ so you get something like /your/modx/base/path/assets/
                Watch out that you don’t get a double slash with copying the MODX_BASE_PATH.

                And of course, save.

                If the problem remains, make sure that folders have proper rights (Check out the link posted before by Andrew Abogado)

                Hope it helps
                Greetings, Kenny

                • I don't find MODX_BASE_PATH in System Info. And I think it could be a configuration and not a problem.
                  Go go Reports, clic on on "see" (to the right of phpInfo() ), and find upload_max_filesize.
                  I would like to try this, but I don't know where to set it smiley Anybody can help me please? Thanks and sorry for my english, I'm from Chile and my native language is spanish. Greetings!
                  • Solved!!! smiley
                    Searching in this forum I found how to change that value (2 MB). By default 2MB is the value, so edit your php.ini (I'm working on windows with apache) and find upload_max_filesize and set a mayor value.
                    Good luck! smiley