Hi,
Installing MODx v1.03 on www.zen.co.uk - I’m new to this host so cannot vouch for their MODx friendliness yet.
All appears okay except for TinyMCE. It doesn’t run when looking at Resource Content and then actions such as Manage Elements result in a Error Message as follows (snipped a bit of the end - more of the same).
include_once() [function.include]: Failed opening ’/blah/public_html/modx/assets/plugins/tinymce3241/tinymce.functions.php’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php:/blah/public_html/modx/manager/includes/’)
Warning: include_once(/blah/public_html/modx/assets/plugins/tinymce3241/tinymce.lang.php) [function.include-once]: failed to open stream: No such file or directory in /blah/public_html/modx/manager/includes/document.parser.class.inc.php(746) : eval()’d code on line 12
Warning: include_once() [function.include]: Failed opening ’/blah/public_html/modx/assets/plugins/tinymce3241/tinymce.lang.php’ for inclusion (include_path=’.:/usr/lib/php:/usr/local/lib/php:/blah/public_html/modx/manager/includes/’) in /blah/public_html/modx/manager/includes/document.parser.class.inc.php(746) : eval()’d code on line 12
Fatal error: Call to undefined function getTinyMCELang() in /blah/public_html/modx/manager/includes/document.parser.class.inc.php(746) : eval()’d code on line 43
Checked tinymce files are there by reloading and document.parser.class.inc.php looks intact too.
I’m suspecting Magic_quotes_GPC which is Off for my localhost but On for zen host. Tried modifying that in .htaccess but results in 500 so cannot test. Or some other Apache/PHP/MySQL setting may be incorrect.
Note during installation the following error occured
Checking database: failed - database collation mismatch; use SET NAMES or choose latin1_swedish_ci
So I used Set Names and all proceeded fine. Worth mentioning.
Parthian