New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Is there a way to make the FCKEditor the default choice for everyone including manager users etc. Right now you have to choose your editor if you are a manager user even though I disabled tinymce in the plugin manager. It seems to default to none after disabling it. I would prefer to only have FCKEditor as the default with no other choices. I have set it to FCKEditor in tools/configuration/interface and features. For some reason when manager users try to edit content they cannot change fonts, font size, colors etc in Tinymce which defeats the purpose of allowing them to modify their own content.
    • It is preferred to not let editors choose their own colors, fonts, etc; all of this should be handled in the template and the CSS. You can configure TinyMCE to have a dropdown menu of various classnames available in your css file.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
      • Unfortunately I wouldn’t know where to begin to customize Tinymce as I’m just beginning to learn how to do this. So your saying that manager users aren’t supposed to be able to change the color of say one word in a paragraph to highlight it (Update for example) or edit/add images or insert a hyperlink to another website? That seems to take the wind out of my sails as I don’t want to keep having to do all the work every time they want something added to the main content on a page. I was hoping that Modx would lighten my workload by allowing the user to add things like images, different colored individual words and urls to other sites. Back to the drawing board I guess. sad
        • So your saying that manager users aren’t supposed to be able to change the color of say one word in a paragraph to highlight it (Update for example) or edit/add images or insert a hyperlink to another website?
          No, she’s saying that you should let your clients do the styling by applying css-classes to html-elements (h1 h2 ... p etc.) which you make available for TinyMCE, rather than to have a palette of manymany colours and font-sizes your client might go berzerk with...(and they will!)

          give your client a certain amount of predefined css-classes to choose from, which reflect your overall website look

          go to "Tools" -> "Configuration" -> "Interface & Features" -> "CSS selectors:" (at the very bottom) in order to enter a list of css-classes you want to make available for your editors
          • Sharkbait, thanks for your reply. I hope I didn’t come accross as ungrateful, that wasn’t my intention. I understand about adding the css styles for fonts etc. But how would I allow them to add/edit an image or replace an existing one? There are no icons to allow this in Tinymce. These clients are only familiar with using word and excel and that is the extent of their experience. Again I apologise if I offended anyone I wasn’t trying to do that.
            • I hope I didn’t come accross as ungrateful, that wasn’t my intention.
              hey nootkan, you haven’t! no worries smiley

              But how would I allow them to add/edit an image or replace an existing one? There are no icons to allow this in Tinymce.
              there should be an icon in your tinyMCE for inserting images, otherwise something’s not rigt with your installation/setting...see attached screenshots.
              there’s also a very handy snippet which will allow your clients to add images with lightbox functionality reallyreally easy -> http://modxcms.com/forums/index.php?topic=19236.0
              • Okay something must be wrong with the upgrade from 9.6.3 to 1.0. If you look at my screen shots you’ll see what I get when signed in as a manager user (top image). Signed in as the admin I see the same thing as in your screen shots (bottom image). Wonder what went wrong and how I will fix it.
                • If you look at my screen shots you’ll see what I get when signed in as a manager user. Signed in as the admin I see the same thing as in your screen shots
                  hmm, there have been some issues with tinymce after upgrades
                  -> e.g. http://modxcms.com/forums/index.php/topic,38400.0.html
                  It seems to default to none after disabling it.
                  did you enable tinymce again and set "Editor to use:" under "Security" -> "Manager Users" -> "Your username" -> "User" -> "Editor to use:" although tinymce is working for manager users in my installation without any predefinition
                  • smiley Sharkbait, thanks for the input. I had set the editor to use to tinymce under "Security" -> "Manager Users" -> "Your username" -> "User" -> "Editor to use. But when I scrolled down a little further I see that I hadn’t changed the theme settings from simple to content editor. Works like a charm now. Funny how a little thing can frustrate the "you know what" out of you sometimes. Thanks again for all your support, really appreciated. wink
                    • good news! smiley