New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Hi Guys,

    I’m starting to go crazy here... and I’m trying to figure out why this could/would be happening.

    I moved a site over to a different server to a production machine, and altered what needed to change to get the app running. Everything was working on the previous server without any dramas at all. But... not so now on the new one.

    Yes, the manager works and everything else. Except two things.

    Captcha graphics. Which I’ll sort out soon (well, I hope this could be related).

    And also rich text editors.

    But... here’s the funny thing about it.

    Modx won’t load the editors on the new server in the manager window... however, it will load the quick editor, and... the WYSIWYG editor fires up beautifully, without problems in the quick editor!

    I can’t figure out why this is happening. I’ve got bugzilla on my firefox browser, and it’s not telling me anything is wrong. It’s just really weird.

    I’d like to think I’m savvy on this sort of thing, and wouldn’t be writing if I couldn’t figure it out.
    Has anyone had this happen? Or am I the first one?

    It’s a tough one. I’ve spent the last several days going over config files, searching through help stuff... not much that I’ve found.

    Thanks in anticipation.

    Cheers,
    Steve
    • Captcha - make sure you have gd library or what else is needed
      • As xpix suggests, GD and freetype are necessary for CAPTCHA to work. Your remote host might have either one turned off. You can run phpinfo() from inside the manager (or put it in a snippet) to find out.

        The other problem sounds more like a bad MODx upload to me. I’d try an upgrade install first. If that doesn’t work, I’d re-upload the files and do an upgrade install again. Someone else may have a better idea.

        Bob
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/MODx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
        • gd and freetype are enabled.

          I’ve just reuploaded the site.

          Still the same problem. grrrr... I’m at witts end here and running out of options.


          I know this may roll heads, but register_globals are on, and this is what I have to live with. (At this stage)


          I guessing it has to be the server config, as I’ve just installed a fresh modx, and it does the same thing. WYSIWYG editor with the quick edit, yet, in the manager area, no WYSIWYG editor. I’ve even tried both FCKEditor as the included TinyMCE one.

          Are there any hard core coders out there that have experienced this and have found a workaround?

          I’ve attached my php settings if that helps.

          The test environment is with go-daddy. The production server is just a normal hosting company.


          Thanks! smiley
          • Try going directly to the graphic image link in the source of the page with the CAPTCHA image on it. That may give you an error message with some clues.

            mod_security is also a possible culprit. Search this forum for mod_security to see if anything rings a bell.

            Another couple of things to try are an upgrade install and, if that doesn’t fix things, re-uploading the files and another install. Sometimes a file or two gets corrupted in the transfer.

            BTW, I don’t have anything that can open your zip file. WinZip and 7-Zip both claim it’s not a valid zip file.

            Bob
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/MODx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
            • That’s weird. I zipped it with windows built in one...  undecided I’ll try again... I had to rename it to .txt though. So, grab it and change the extension, as it’s an html file.

              My next step is to get in contact with the server company and see what’s going on... or not going on for that matter...


              I ask the question too though, would it be possible the manager can’t find the WYSIWYG plugin/editor?

              Further to the captcha image... all I get is the address I’ve just typed in. No error. No nothing.

              just this code:

              <html>
              <body>
              <img src="http://www.xxxxxxx.com.au/v2/manager/includes/veriword.php" alt="http://www.xxxxxxxxxx.com.au/v2/manager/includes/veriword.php"/>
              </body>
              </html>
              • If you paste just this part: ( http://www.xxxxxxx.com.au/v2/manager/includes/veriword.php ) into the address window of your browser and don’t get an image, it pretty much indicates one of two things: Either the host’s graphics package is broken/misconfigured, or your veriword.php file is corrupt.
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/MODx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                • Quote from: vr_driver at Jul 09, 2008, 11:24 AM


                  I ask the question too though, would it be possible the manager can’t find the WYSIWYG plugin/editor?

                  Hmmm. . . In the MODx Manager, look at Tools | Configuration | Interface & Features tab.

                  Check the settings of Resource Path, Resource URL, and Editor to Use.
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/MODx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                  • Also check the User tab for your individual manager users. (Security -> Manager Users)
                      Studying MODX in the desert - http://sottwell.com
                      Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
                      Join the Slack Community - http://modx.org
                    • I’ve only got one user... the admin.


                      Hi Guys...

                      Well. A strange update for you.

                      I have managed to get the site working with the WYSIWYG editor. But you would have never guessed it.

                      The ’bottom button bar’ plugin was causing a conflict somewhere and not making things work. Weird.

                      Thanks for the suggestions though. I did appreciate them. Now on to other things... like the veriword thing... ha ha.