New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Hi, the image editor that is used with tinymce 3.03 mcpuk does not work for me. The image does not show up in the editor, but it does show up in the mcpuk file manager. I think the image is within an iframe generated through a php file.

    Anyway, if anyone knows how to fix it or can help me, please do  grin
    • Check the configuration of the plugin itself. What is the Path Options set to? Try it at docrelative and see if that works. Tried to cover all the bases for that but there might be a path setting that’s off for you. What kind of server is this on?
        Jeff Whitfield

        "I like my coffee hot and strong, like I like my women, hot and strong... with a spoon in them."
      • Thanks for your help.

        it points to the image here

        http://mydomain.com/manager/media/ImageEditor/assets/images/image.gif

        instead of here

        http://mydomain.com/assets/images/image.gif

        maybe something to do with this line

        <iframe src="editorFrame.php?img=<?php if(isset($_GET[’img’])) echo rawurlencode($_GET[’img’]); ?>" name="editor" id="editor" scrolling="auto" title="Image Editor" frameborder="0"></iframe>


        (its an apache server)
        • Check your configuration under Interface & Features. What is the Resource path and Resource URL options set as?

          Also, look at the source code for the instance of TinyMCE that’s causing the problem (might be in a frame within the manager). You should see a function called myFileBrowser. What’s the value of the variable called cmsURL? Just want to ensure that the serverpath is set properly.
            Jeff Whitfield

            "I like my coffee hot and strong, like I like my women, hot and strong... with a spoon in them."
          • /home/southq/public_html/assets/

            and..

            /assets/

            I dont know where to find the function myfilebrowser

            this?

            	function myFileBrowser (field_name, url, type, win) {		
            		var cmsURL = '{$tinyURL}/mcpuk/browser.php?Connector={$tinyURL}/mcpuk/connectors/php/connector.php&ServerPath={$base_url}&editor=tinymce3&editorpath={$tinyURL}';    // 


            • How about this....could you PM me and give me the URL of the site as well as a user/pass I can use to login to the manager? Don’t worry. Won’t mess anything up. Figure it would be easier if I just took a quick peek at what’s going on. laugh
                Jeff Whitfield

                "I like my coffee hot and strong, like I like my women, hot and strong... with a spoon in them."
              • At line 73, I’ve add a / juste before the path’s picture

                For me it’s ok, I hope for you to.

                Bye.

                Mitch
                • In which file?