On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I am experimenting with YAMS and I can’t configure the base URL. I have my website in a subfolder and whenever I switch on my template as multilingual, YAMS redirects me to the server root.

    I first looked at .htaccess but I now think that it is the plugin because the <base href="(yams_server)"></base> outputs the server root url rather than the website base url. I have tried to change the "server name" in the language parameters tab but when I submit, it reverts to the previous value.

    Can somebody help me?
    • There’s a setting in the "Other Params" tab, near the bottom, "MODx Subdirectory".
      If MODx is installed into/configured as active within a subdirectory, eg: http://www.mysite.com/sub1/sub2/index.php, then this parameter should be set to the subdirectory path: sub1/sub2 with no trailing or leading slash.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
      • It works smiley

        I must have been starring too much at the screen to not see this. Thank you for your help.