On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • ..to be honest..all the advices above seem a bit rumours to me...
    Here my solution
    additional Ditto Parms:
    &tplPaginateNext=
    <a href="(yams_doc)[*phx:input=`[+url+]`:getUrlQuerystring*]" class="ditto_next_link">[+lang:next+]</a>

    &tplPaginatePrevious=
    <a href="(yams_doc)[*phx:input=`[+url+]`:getUrlQuerystring*]" class="ditto_previous_link">[+lang:previous+]</a>

    and this is the additional phx:extender "phx:getUrlQuerystring" (used in Ditto Call, &phx=0 because of YAMS):
    <?php
    return strstr($output,'?');
    ?>


    I suppose this isnot the problem solved at its root, but I don’t have a smarter idea. At least I can follow this solution by my mind.

    regards
    manu
    • Thanks manu, this solution is working.

      But, I can't still get to work [+pages+] placeholder , it's always shows links of default language.
      • Is there any ready solution for the correct working YAMS+Ditto placeholder [+pages+] ?
          Правильно заданный вопрос повышает вероятность получения нужного ответа.
          Что-то не работает? Загляните в лог ошибок!
          Есть проблема? "Локализуйте" её!
          Ответы на большинство вопросов по MODx | MODx RTFM | API Evo Revo | галопом по Европам Азиям smiley wikibooks(ru) Ditto(en) | Wayfinder e-book | Заметки и о MODx
        • hi, not sure to understand where your problem is but (well, with yams last release) the placeholders are
          [+(yams_id)_previous+] [+(yams_id)_pages+] [+(yams_id)_next+]
          and i haven't ran into any problem with them

          have swing
            réfléchir avant d'agir
          • Hi Folks. I am on MODx 1.0.6 with YAMS 1.2.0rc3 and I tried all the tips here, and it is absolutely not working for me. I never saw 1 pagination whatsoever. Ditto is showing my content well, but pagination simply doesn't work. On some tips here, I get file-not-found errors in my php_log, like: media/script/scriptaculous, media/script/modx.js, media/script/cb2.js But I managed to get those out (not sure what triggered them, its old stuff I guess).

            I uncached the page where I'm making the Ditto call. I did the YAMS config adjustments which were mentioned in this topic, although I don't seem to need them for 1.2.0rc. Still I don't have ANY result with pagination. I'm just wasting time. As I understand there is no valid nor complete documentation how to do this? Different people seem to have success with different approaches. But none are working for me which is frustrating. Does anyone have any insights about the fully and correct way to set this up ? I see people are working around with PHx but normally I hardly use PHx so I'm getting stuck there too sad If anyone has any insights.. I'm tipping Santa to treat you very well this year smiley

            I do this ( page-tpl's are explained previous in this forum topic) :
            Ditto? &parents=`127` &orderBy=`pub_date DESC` &tpl=`tpl_news` &id=`(yams_id)` &display=`all` &paginate=`1` &paginateAlwaysShowLinks=`1` &summarize=`3` &dateFormat=`%d %m %Y` &extenders=`@FILE assets/modules/yams/yams.extender.inc.php` &language=`(yams_mname)` &tplPaginatePage=`pageSplitter` &tplPaginateCurrentPage=`currentPageSplitter`
              Accelerate your Windows system with 9.8 m/s2.