On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Heyas=)

    I need to make the SEO Strict URLs plugin work on my site so i can output a xml file with the .xml suffix.

    At the moment i use .html as basic suffix in friendly urls, so ALL files has .html behind them - also my xml files. With the Seo strict plugin i can tell it to exclude suffix on a specific page using a tv, and then i can name the page alias something.xml and it will output with out .html

    plugin: http://modxcms.com/extras/package/395

    I think that yams is conflicting with the plugin, i can’t get it to work at all!

    If there is another way to achieve my goal with out the plugin im listening laugh

    Thanks!!!
    regards norlins
    • Here’s how to achieve what you want:

      1. Disable/Uninstall the SEO Strict URLs plugin. YAMS has its own in-built in SEO strict functionality which conflicts with that plugin.
      2. Set Modules>YAMS>Other Params>URL Formatting>Use Mime-type dependent suffixes? = Yes.
      3. Clear your cache.

      That should be it. The default MIME => suffix mapping is as follows:
        $this->itsMimeSuffixMap = array(
          'application/xhtml+xml' => '.xhtml'
          , 'application/javascript' => '.js'
          , 'text/javascript' => '.js'
          , 'application/rss+xml' => '.rss'
          , 'application/xml' => '.xml'
          , 'text/xml' => '.xml'
          , 'text/css' => '.css'
          , 'text/html' => '.html'
          , 'text/plain' => '.txt'
          );
      

      If you want to change it, you will have to edit the assets/modules/yams/yams.config.inc.php file directly.
        YAMS: Yet Another Multilingual Solution for MODx
        YAMS Forums | Latest: YAMS 1.1.9 | YAMS Documentation
        Please consider donating if you appreciate the time and effort spent developing and supporting YAMS.
      • PMS <3 <3 <3

        THANKS !!! grin grin