the problem for me was the new TagCompleter is called before jquery loads from my server, on firefox it happens after new TagCompleter, I had same problem in other sites which loaded jqGrid, that was a big js script, it takes some time to be downloaded and parsed executed from browser, it seems script onload happens after document.onload event, so I need to test when a particular script is loaded with
if (script.readyState)
script.onreadystatechange = function(){
if (script.readyState == "loaded" || script.readyState == "complete"){ ....
to wait jquery is loaded, after I can intantiate TagCompleter
I have just experienced this problem - possibly caused by the fact that I have MODx installed on a subdomain? It was working when I set the site up, but now errors.
I run MODx on my main domain - this is working fine.
I have a separate installation of MODx within a sub-domain, and this is throwing the "TagCompleter" error when I click on a resource.
MODx version 1.0.3, MM 0.3.8, JQuery 1.3.2
Do I need to somehow amend the htaccess file within my manager folder on the subdomain?
-
☆ A M B ☆
- 91 Posts
For those who find this thread and are still having the problem with old versions of MODx Evolution, here’s how I fixed it on one of my sites: I disabled the .htaccess file in the /manager/ folder. (Evo 1.0.3)
WebsiteZen.com - MODX and E-Commerce web development in the San Francisco Bay Area