On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • This may be in the wrong section, so forgive me if so.

    I have the most current version of Revo and all has been good to go. I uninstalled the Captcha snippet from the package manager, as we no longer needed it.

    I logged out and now I can’t get back in. I have "login_mathstring_message" in place of the old captcha, and I can’t get rid of it. I even looked in DB tables. I didn’t find anything that looked like it would help.
    • For those who get locked out like me, this is how I just got around it.

      Look in /core/cache/mgr for "context.cache.php".

      Look about half way down the file for the following code:

      'locked' => 0,
      'properties' => NULL,
      'disabled' => 0,
      'moduleguid' => '',
      


      Change ’disabled’ => 0 to ’disabled’ => 1. You should now be able to get in.
      • Bump. same issue, but the fix doesn't work for me. Ideas?
        • Edit the core\cache\system_settings\config.cache.php file.

          Change the captcha.enabled setting line to:

          'captcha.enabled' => '',


          That should get you in.

          Once in, immediately go to System -> System settings.

          Type 'captcha' in the search box at the upper right and press enter.

          Change the captcha.enabled setting to 'No'.

          Click somewhere else in the grid.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
          • Quote from: BobRay at Jun 11, 2013, 08:17 AM
            Edit the core\cache\system_settings\config.cache.php file.

            Change the captcha.enabled setting line to:

            'captcha.enabled' => '',


            That should get you in.

            Once in, immediately go to System -> System settings.

            Type 'captcha' in the search box at the upper right and press enter.

            Change the captcha.enabled setting to 'No'.

            Click somewhere else in the grid.

            Hi BobRay

            I am using MODx Revo 2.2.7 and I can't seem to find

            'captcha.enabled' => '',


            anywhere in my core/cache/system_settings/config.cache.php file. I only see lines relating to 'recaptcha'.


            Problem
            In my manager log in window I am seeing

            login_mathstring_message


            with a missing image and then 'captcha_mathstring_code:'.

            I didn't activate the captcha on the login form. But I must have inadvertantely switched it on when I turned it on for a FormIt Contact form within my site.

            How can I deactivate the Captcha code now that I can't log in to the manager?

            Thanks!
            Sar
            • Sorry, I should have told you what I've tried. I've tried

              • Manually clearing the core/cache files
              • Going into the database and deleting the public and private key values for 'recaptcha.private_key' as well as 'recaptcha.public_key'
              • Tried different browsers, but still seeing the same thing

              I don't know what to try next?
              • Hi BobRay..and anyone else that might find this useful,

                Situation
                I installed Captcha through Package Management yesterday because I was trying to add it to Formit. But then I uninstalled it when I realized that you could use reCaptcha (which is a different thing) with Formit.

                Problem
                But then this morning when I tried to login to the manager, I was met with a Captcha code that was missing the image so I couldn't login even if I tried. Also, above the manager login was '$_SESSION Variable not set' in red.
                I thought that I must have left Captcha installed so I tried out the solutions from this post (as well as some others) but couldn't find anything that worked. So what I had to do:

                Solution
                I went into my MySQL and searched for the term "captcha" which led me to change a few values in my tables. Change:

                Go to 'website_site_plugins' then find the row related to 'Captcha' and change 'disabled' to '1' and then go to 'website_transport_packages' and find the row that says 'captcha-3.3.0-pl' and change 'disabled' to '1'

                What's weird though, when I logged in to check if I had Captcha installed or not, I was confused to see that it wasn't even installed. So I removed it, which seemed to fix the issue altogether, thankfully.
                • Thanks for the feedback. smiley

                  I think what happened to you was that the Captcha plugin was still in the cache, so MODX tried to use it when you logged in. Deleting the files in the core/cache directory might have solved it. I've made some changes so this shouldn't happen in the future and released Captcha 3.3.1-pl.

                  http://modx.com/extras/package/captcha

                  BTW, an easier solution when Captcha prevents you from logging in (for whatever reason) is to edit the core/cache/system_settings/config.cache.php file.

                  Change this line:

                  'captcha.enabled' => '1',


                  to

                  'captcha.enabled' => '',


                  Important! As soon as you log in, go to System -> System Settings and change that setting again so the change will be permanent.


                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                  • Quote from: BobRay at Aug 09, 2013, 04:52 AM
                    Change this line:

                    'captcha.enabled' => '1',


                    to

                    'captcha.enabled' => '',

                    Hi BobRay,

                    Unfortunately, I couldn't find that line in my core/cache/system_settings/config.cache.php file. That's why I had to go to my database and change a few things manually. What's strange is that this morning I was shown the mathstring window again even though I've uninstalled and removed Captcha. So I had to go back into the database and edit the 'website_site_plugins' table.

                    Thanks for your help!
                    Sar
                    • The Captcha plugin was still in the cache. Deleting all the files in the core/cache directory would have solved it.

                      If you can't find the Setting in the table, you can set it in the modx_system_settings table and delete the cache files to get in.


                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting