On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I had to restore my domain so, I backed up the entire file directory and database. I’ve restored everything, everything seems to work fine except for the ’forgot manager login’. I get the following error when I log into the manager;

    Forgot Manager Login - OnBeforeManagerLogin
    An error occurred while loading. Please see the event log for more information.

    Parse error: syntax error, unexpected ’-’, expecting ’}’ in /var/www/vhosts/<mydomainname.com>/httpdocs/manager/includes/document.parser.class.inc.php(742) : eval()’d code on line 100



    --------------------------------------------------------------------------------

    Forgot Manager Login - OnManagerAuthentication
    An error occurred while loading. Please see the event log for more information.

    Parse error: syntax error, unexpected ’-’, expecting ’}’ in /var/www/vhosts/<mydomainname.com>/httpdocs/manager/includes/document.parser.class.inc.php(742) : eval()’d code on line 100


    thanks in advance
    • heya, i don’t usually practice thread necromancy, but in this case i’d thought it usefull to provide an aswer to this problem even if it’s an old post, since i just had this problem now, with evolution 1.0 and this was the only relevant google search i found. So here it goes.

      If you’re getting this error it means that the plugin responsible for providing the little "Forgot your password?" link on the /manager/ loging page is missing, broken or out of date. Anyway, it’s not working. The link does not appear there and the login button sits awkwardly in the HTML now because of it.

      Sollution:
      1. re-copy the install directory to your website (make sure it’s from the exact same version you’re using)
      2. go to www.yourwebsite.com/install/ - the install wizard will appear, select next
      3. make sure to select UPGRADE
      3. once you reach the optional components page, make absolutely sure to UNCHECK everything including the ’install sample website’ option, everything should be unchecked.
      4. on the same page, look under Plugins and CHECK (select) "Install/Update Forgot Manager Login - Resets your manager login when you forget your password".
      5. agree to the terms and proceed with the install.

      If install goes well it’s going to report updating the Forgot Manager Plugin and next time you log in everything will be fine, the link will be there and no more error messages in manager.

      Hope this helped (judging after the number of views on this thread, it should help at least a few people)

      Peace.
      • to further add to the thread necromancy smiley
        i had the same problem, but didn’t want to do an upgrade install... so i opened up the forgot manager login plugin, checked the source code and there it was...
        some phpmyadmin-stuff in some weird places of the code. i remember having that problem with some other database-dumps from phpmyadmin.
        i removed the lines added by phpmydamin (looked something like "phpMyAdmin463e7a7394c8730f4508"), and the problem was gone.
        maybe this helps someone. smiley