On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi please could someone help...?

    I’m trying to get the WebUser Login Home Page redirect to work and I just cant see why it wont (I’ve been trying and searching for sometime!)

    I’ve tried it in 0.9.6.3, and am now using 1.0.0 on a default installation.

    Without even getting into document groups and user groups yet, I’ve created a page which is excluded from the menu, created a WebUser, and set their Login Homepage to be the ID of the new page but it just goes to the site homepage everytime.

    Ultimately what I need to achieve is a secure login for clients who are redirected to their own homepage, any advice on the most satisfactory solution for this would be most appreciated.

    I’ve looked around and many people seem to have similar problems but I can’t find a definitive solution.

    Many thanks for your help in advance!

    Jon

    • Just pushing this up again

      Can anyone help please?
      • Is the home page the unauthorized page (setup in the manager)? That might explain why it goes to the home page. You can also try to use the [(login_home)] tag n the snippet call:
        [[WebLogin? &loginhomeid=`[(login_home)]` &logouthomeid=`1`]]


        And make sure that the page has the correct group assigned to it, needs to have the same group that the user will have.
          [font=Verdana]Shane Sponagle | [wiki] Snippet Call Anatomy | MODx Developer Blog | [nettuts] Working With a Content Management Framework: MODx

          Something is happening here, but you don't know what it is.
          Do you, Mr. Jones? - [bob dylan]
        • Thanks for you prompt reply! smiley

          I’ve checked and the unauthorized homepage was set to the homepage, but changing this has made no difference, infact if you try an incorrect login it still just reloads the hompage and doesn’t show an error message.

          I’ve also replaced the snippet call with the one you suggested but it still doesn’t work.

          I’ve tried it with a user and resource group set up correctly, and also without any groups and neither seems to affect it.

          Any other thoughts?
          • Maybe try with WebLoginPE version of the script?

            Will it work if you put an ID as the parameter for the webloginhomeid? like &loginhomeid=`11` ?
              [font=Verdana]Shane Sponagle | [wiki] Snippet Call Anatomy | MODx Developer Blog | [nettuts] Working With a Content Management Framework: MODx

              Something is happening here, but you don't know what it is.
              Do you, Mr. Jones? - [bob dylan]
            • Thanks again for your help!

              Just tried with an ID parameter and still nothing happens at all.

              Does the WebLoginPE work with the same &loginhomeid=`[(login_home)]` setting?
              • I’ve got WebLoginPE working perfectly when I specify and actual numbered ID, however I can’t seem to see how to pull the [(login_home)] from the user.
                Is it involving LoginHomePage()?

                Any help would be greatly appreciated!

                Cheers

                Jon
                • Seems that somehow the login_home variable is not being set correctly. Do you get a doc id if you simply add the [(login_home)] placeholder on a page after logging in? This will let us know if the placeholder is outputting correctly.
                    [font=Verdana]Shane Sponagle | [wiki] Snippet Call Anatomy | MODx Developer Blog | [nettuts] Working With a Content Management Framework: MODx

                    Something is happening here, but you don't know what it is.
                    Do you, Mr. Jones? - [bob dylan]
                  • Hi, I just tried that in the html editor and it returned the ID in the logged in page correctly.

                    I then went back into the template and replaced the fixed ID in for&liHomeId with [(login_home)] and it started to go back to the homepage again!?

                    Surely that should work?