We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 7045
    • 225 Posts
    I am not sure if this is more of a Windows issue or Weblogin PE issue, so I have posted this in two sections. I apologize if I shouldn’t have done that.

    Ok, I recently moved a client’s site to a Windows IIS server. We haven’t needed to use the login yet, but we will by next week. On the Linux server, Weblogin PE worked perfectly. However, on the Windows IIS server, I am having an issue I can’t solve.

    I have a link on the home page that takes you to the login page. Everything on that login page works great. However, if you are not logged in, and you go to click on a link to a secured page, the browser serves up a login box. On the Linux server, instead of the box, you get the custom "Unauthorized" page I built and set MODx to use. This is the correct functionality, if i am not mistaken. Now even though this is annoying, it is not the real issue. The real issue is that when I try to use the login box the browser is serving, I can’t log in. I have tired every username/password I have.

    Why is this happening, and how do i keep the box from popping up, so i can use my "Unauthorized" page instead?

    I hope all that made sense.
      • 7045
      • 225 Posts
      And encase it helps, it is the server that won’t let me login, not MODx. Here is the error I get:

      401 - Unauthorized: Access is denied due to invalid credentials.
      You do not have permission to view this directory or page using the credentials that you supplied.
        • 7045
        • 225 Posts
        I forgot to add another important bit of info, we DON’T have user friendly URLs activated. Come to think of it, I recall reading somewhere that you may need to modify some of the code to make PE play nice w/out UF URLs activated.

        Also, we have set all permissions correctly, I think. However, that damn popup login box won’t go away.