We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 7045
    • 225 Posts
    Here is the error I am getting....

    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource:
    « PHP Parse Error »
     
    PHP error debug
      Error: 	include_once(/home/dkraus13/public_html/assets/snippets/webloginpe/webloginpe.class.php) [function.include-once]: failed to open stream: No such file or directory	 
      Error type/ Nr.: 	Warning - 2	 
      File: 	/home/dkraus13/public_html/manager/includes/document.parser.class.inc.php(769) : eval()'d code	 
      Line: 	27	 
     
    Parser timing
      MySQL: 	0.0036 s	(4 Requests)
      PHP: 	0.0402 s	 
      Total: 	0.0438 
    


    Here is the call I am using....

    [!WebLoginPE? &type=`simple` &regType=`instant` &regRequired=`email,username,fullname,password,formcode`!]
    


    WebLoginPE works great locally on XAMPP, but it spits out this error once I move the site to a live server. I am guessing this is probably something simple I am not seeing. I have the login on it’s own page. When I click the link to access the page, I get the above error. When I delete the call, I can access the page no problem. Again, it works fine locally.

    TY in advance.
      • 5253
      • 17 Posts
      Heyya,

      does the file weblogin.class.php exists in /home/dkraus13/public_html/assets/snippets/webloginpe/ ?
      Seems to me, that there’s a simple file directory problem...
      Have you entered the correct paths in the Modx Manager?
      I don’t know the English menu title but in German it’s:
      Werkzeuge > Konfiguration > Benutzeroberflaeche
      Werkzeuge > Konfiguration > Sonstiges

      These path’s have to match you webserver’s file system as well...

      good luck smiley
        *there are no strangers - just friends who never met*
        • 7045
        • 225 Posts
        Ya, the file exists, and I am almost positive the paths are correct. Let me double check, I wouldn’t be surprised if I over looked it on the live site.

        TY
          • 7045
          • 225 Posts
          Ok, forgive my noobishness, but here we go. The file exists, and the paths in the backend are correct. So this is what I am left with.

          1. Would it matter if I don’t have friendlyURLs activated? I can’t do that until I switch over the DNS, which won’t happen until the site is done. I don’t see why that would matter, as it works locally with/without friendlyURLs.

          2. Is there a section in any of the webloginpe files where I may need to change the path, because I am not seeing it if there is. In other words, do I only have to change the paths in the manager, or does this snippet sometimes require you to go into the code to change it as well.

          I know this something small I am over looking, and it is driving me crazy.
            • 7045
            • 225 Posts
            I don’t think it is permissions. Folder is 755 and file is 644.
              • 4310
              • 2,310 Posts
              Are you sure the folder is actually named webloginpe and not something like WebLoginPE ?
                • 7045
                • 225 Posts
                Oh, that sounds like it could be it. Let me check.
                  • 7045
                  • 225 Posts
                  Holy shit, that solved it. Thanks for all the help guys.
                    • 4310
                    • 2,310 Posts
                    I thought it might be the issue when I checked an unzipped a later version.
                    Glad it’s sorted now grin
                      • 7045
                      • 225 Posts
                      Ya, I was starting to feel the pressure as my deadline got close, and the fact that I knew it was something easy was making me crazy. I really do appreciate all the help. One great CMS and an even better community.