I went ahead and deleted all of the web_user tables, and it still gave the "username already exists" error.
I’m gonna poke around into WLPE’s coding and see if I can figure out what the issue is...
EDIT: I forgot to mention that WLPE is sending out the "welcome to this website" e-mail, as well as adding the user. It’s just throwing out a username error, and will not add them to the Reg. Users group.
$checkUsername = $modx->db->query("SELECT `id` FROM ".$web_users." WHERE `username`=’".$username."’");
$limit = $modx->recordCount($checkUsername);
if ($limit > 0)
{
return $this->FormatMessage($this->LanguageArray[7]);
}
$lowercase = strtolower(str_replace(’ ’, ’_’, $username));
if ($lowercase == ’default_user’)
{
return $this->FormatMessage($this->LanguageArray[7]);
}
$checkEmail = $modx->db->query("SELECT * FROM ".$web_user_attributes." WHERE `email`=’".$email."’");
$limit = $modx->recordCount($checkEmail);
if ($limit > 0)
{
return $this->FormatMessage($this->LanguageArray[8]);
}
Anyone good enough to notice if there is a bug that would trigger the "username already exists" when no users are in the database at all? WLPE is the center of the interactive side on my website, so it’s very important that I try to get this resolved ASAP.