We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 4018
    • 1,131 Posts
    Hey Taff, I’m getting a "Redefining already defined constructor for class WebLoginPE" error for the code you posted at the beginning in System Events. After the error it shows the pagination links so it’s gotta be something with the pagination scripts. Any idea why that is happening?
      Jeff Whitfield

      "I like my coffee hot and strong, like I like my women, hot and strong... with a spoon in them."
      • 29181
      • 480 Posts
      I have no idea Jeff, especially as I never had any issues when I threw it together.

      Maybe you are using a newer version of WLPE than I was?

      I can take a look at the source code over the weekend, and maybe I’ll be able to see why.

      Taff
        Adrian Lawley: www.adrianlawley.com
        • 18878
        • 210 Posts
        Hi smiley

        I have around 60 users in my website so I decided to use the pagination feature. The WebLoginPE version I’m using already had the pagination features presented by Taff, so all I had to do was add the &paging=`15` param.

        When testing the pagination, I noticed that the sort order was incorrect. For example, when not using the paging param, my total user’s list display like this:
        aa
        ai
        au
        ba
        bi
        bu
        ca
        ci
        cu

        And when using the paging param, the display looks like this:

        page 1:
        aa
        ba
        ca

        page 2:
        ai
        bi
        ci

        page 3:
        au
        bu
        cu

        That’s very strange, it looks like the sort order is somehow randomized. Did this happen to you? Any clues about a solution?

        Thanks in advance.

        Mc
          • 29181
          • 480 Posts
          I haven’t done anything on that website for a long time, but I think I may still have access.

          I’lll take a look later if I get a chance. I vaguely remember a logic error initially whereby it was sorting them by page, and not by total at the beginning.

          Taff
            Adrian Lawley: www.adrianlawley.com
            • 18878
            • 210 Posts
            Quote from: Taff at Nov 03, 2008, 11:26 AM

            I haven’t done anything on that website for a long time, but I think I may still have access.

            I’lll take a look later if I get a chance. I vaguely remember a logic error initially whereby it was sorting them by page, and not by total at the beginning.

            Taff

            Thank you Taff, I hope you can find a solution. Looking forward to it.
              • 29181
              • 480 Posts
              Well it appears to work OK on the site I created it for.

              I don’t know when you need it for, but unfortunately I’m not going to be home for a fortnight. I don’t have FTP access to take a look and download the file in the meantime. If you can wait that long, please send me a PM in about 2 weeks (the 22nd would be good) and I will download and see if I can find the error.

              Sorry for the late reply.

              Taff
                Adrian Lawley: www.adrianlawley.com
                • 18878
                • 210 Posts
                Quote from: Taff at Nov 11, 2008, 10:34 AM

                Well it appears to work OK on the site I created it for.

                I don’t know when you need it for, but unfortunately I’m not going to be home for a fortnight. I don’t have FTP access to take a look and download the file in the meantime. If you can wait that long, please send me a PM in about 2 weeks (the 22nd would be good) and I will download and see if I can find the error.

                Sorry for the late reply.

                Taff

                Thanks Taff. I’ll PM you the 22nd.
                  • 14397
                  • 14 Posts
                  Hello Taff,

                  I am having the same sorting issue as mcclausky. Could you please provide any information how to solve this?
                  Thank you very much in advance.
                  Klaus
                    • 18913
                    • 654 Posts
                    I think I’ve solved this, at least for the case of sorting on a field in the "attributes" table. To change to solution to a field in "extended" is trivial, but I don’t yet have a fully-general query that can handle all three tables at the same time. Nevertheless, keeping in mind that the testing has been limited, see :
                    http://modxcms.com/forums/index.php/topic,47534.msg279724.html#msg279724
                    MattC