On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hio!

    I’m trying to set up Jot on my site and it sorta works, but not quite enough to be satisfying grin

    I have it running on a test page, with this call (in a chunk, called in the template) ::
    [!Jot? &pagination=`5` &moderated=`1`!]

    I can add comments, which are unpublished (&moderated works at least), then go to that page with my manager account and I see the publish/delete/edit buttons, but if I click on any of them, the page reloads and the buttons disappear, with no change to the comments (i.e. nothing gets published/deleted etc). If I turn on CAPTCHA in the snippet call, it works once, and then from that point on rejects whatever I put into the CAPTCHA input, regardless of whether or not its correct -- and yes, it is turned on in Tools>Configuration>User area.

    I am unsure of what to do next..I’m hosted on fatcow, and have some other strange behavior going on when logging into the manager (though it doesn’t prevent me from logging in, just annoying).

    Any help would be greatly appreciated.

    thanks!!
    • A further complication: I have friendly urls/url alias turned on. If I go to my comment test page (while logged in as manager) with the alias (i.e. /comment.html), I see comment posts, but no post/edit/delete options. If I instead go to the page using /index.php?id=5, all of the editing stuff is there.. but when I click the buttons it reloads the page using the alias! Huh?
      • O_O I turned off friendly urls and it miraculously works. So the question is now...how do I get Jot to work correctly with the friendly urls on?
        • Fixed! For those of you wondering what was going on...

          It was my host, Fatcow. I migrated the site to a different host and everything works perfectly now. Go figure, I guess.
          • I am experiencing the exact same problem as described here.
            A change of host is not an option for me though, so where does that put me?

            Friendly URLs are on, and have to be.
            • I’m also unable to edit comments, delete comments, or modify comments. Wondering if this is a Jquery conflict or if there is a setting in plugin configuration that needs to be changed?