We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21341
    • 26 Posts
    Hello there from germany,

    i have modx running on another server since a year and am very pleased with it.
    Now i am trying to set up another site with modx on a different server. At first i installed v0.9.6.1.p2, but had parse errors a lot of times.
    Then i discovered the latest modx version and installed v0.9.6.2.

    The urls werent my friends, sometimes modx worked, sometimes it dont. I changed the automaticly created base_path etc and the links worked but blog/ditto.
    But there is a deeper problem, that might cause the ditto parse errors: my server is a little bit tricky, sometimes i have to edit the url, adding a explicit www and sometimes i have to cut it out. For now i use the automatic url detection

    And now the technical informations:
    running on a apache server without mod_rewrite, not using htaccess
    modx version is 0.9.6.2 with Ditto 2.1
    nothing is modified, using the example pages
    all the needed file are there, i uploaded the previous version several times and tried, but now i need professional help

    The output looks like:

    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource:
    « PHP Parse Error »

    PHP error debug
    Error: require_once(manager/includes/sniff/phpSniff.core.php) [function.require-once]: failed to open stream: No such file or directory
    Error type/ Nr.: Warning - 2
    File: /var/www/xx/html/mx/manager/includes/sniff/phpSniff.class.php
    Line: 22
    Line 22 source: require_once($modx->config[’base_path’] . ’manager/includes/sniff/phpSniff.core.php’);

    Since i am not using any beta version of modx or ditto i hope someone can help me, because i didnt find any solution posted on the web yet.

    Thanks for helping smiley

    EDIT:
    i just deleted the example pages and created my own ditto page with this call
    <ul> [[Ditto?parents=`0`&depth=`0`&dateSource=`editedon`&dateFormat=`%B %e, %Y at %r` &display=`10`&sortBy=`editedon`&filter=`hidemenu,0`]] </ul>
    And now the snippet works fine and shows the latest 10.

    I dont know what caused the prior problem but.... it works.
      • 25663 MODX Staff
      • 12,272 Posts
      It was saying the file could not be found:

        Error:    require_once(manager/includes/sniff/phpSniff.core.php) [function.require-once]: failed to open stream: No such file or directory    


      Sounds like a partial or corrupt upload...
        Ryan Thrash, MODX Co-Founder
        Follow me on Twitter at @rthrash or catch my occasional unofficial thoughts at thrash.me
        • 21341
        • 26 Posts
        Quote from: rthrash at Sep 18, 2008, 09:12 AM

        It was saying the file could not be found:

          Error:    require_once(manager/includes/sniff/phpSniff.core.php) [function.require-once]: failed to open stream: No such file or directory    


        Sounds like a partial or corrupt upload...

        My first thaught but all files were/are there and it does not explain the working ditto after minor changes (see my edit below).
          • 21341
          • 26 Posts
          After testing a lot of things, deleting and creating, i need help! Some parts doesnt work proberly.

          I reinstalled the example pages but get after clicking blog the parse error. I already changed the config manually or tried to avoid the $modx->config[’base_path’ call in e.g. snippet ditto but the error insists to bother me.

          Some other users had similar problems but i use a valid table prefix and for my excuse am using modx on another server. The provider doesnt have a clue what might went wrong for the server is working correctly.

          I will test it a third time, deleting the db and files, uploading all again and installing modx, but my nerves are getting thin.

          Any help appreciated.

          BTW: i tested drupal and got the same error. After contacting my provider it came out that it was a bug in drupal.


          Solution:
          i solved the problem by editing the manager/includes/sniff/phpSniffclass.php.
          Changed line 22:
          require_once($modx->config['base_path'] . 'manager/includes/sniff/phpSniff.core.php');

          to
          require_once('phpSniff.core.php');

          The script dont have to be dynamic with paths for calling scripts out of the same direcory. And it worked.

          But then i got this:
          PHP error debug
          Error: include_once(assets/modules/quick_edit/output.class.inc.php) [function.include-once]: failed to open stream: No such file or directory
          Error type/ Nr.: Warning - 2
          File: /var/www/xx/html/mx/manager/includes/document.parser.class.inc.php(745) : eval()’d code
          Line: 70
          One user reports a similar problem (posted somewhere here), disabled Quickedit and it works for him. So did I.