We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 28215
    • 4,149 Posts
    This is an auto-generated topic for PackMan 1.2.0-rc1 by splittingred.

    Brief Description:

    PackMan is a Transport Package building tool for packing up Templates, TVs, Snippets, Chunks and other Packages into a Transport Package, ready for distribution.
    New in 1.2.0

    • Subpackages now install into packages grid and can be updated

    New in 1.1.0

    • Added French, German translations
    • Fixed authorization check bug
    • Added ability to save package setup into "Profiles" for easy reloading
    • Added ability to package in Plugins, automatically adds Plugin Events
    • Added ability to package in stand-alone directories for file transfers

    See official documentation here:http://rtfm.modx.com/display/ADDON/PackMan
      shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
      • 17422
      • 225 Posts
      Hi Shaun,

      i try to use packman with modx 2.0.5 pl - Safari

      i have a error :

      Failed to load resource: the server responded with a status of 500 (Internal Server Error)

      all my folder are 755 permission

      i just try with one template.

        • 1423
        • 24 Posts
        Hi

        I just used packman for the first time and I would like to suggest a feature for an upcoming version:

        I have a site which uses a lot of chunks and it would be much easier if I could either drag and drop them, have checkboxes instead of a dropdown list, or if I could import whole chunk categories.

        just my 2cents

        Thanks for consideration

        Thomas
          • 34120
          • 236 Posts
          I’m packaging some directories with packman ie. adding a ’css’ directory to assets. It seems when I then use this package I can’t write to the directory ’css’ which is created. Presumably because of ownership (MODx would be the owner of the files/directory) this also means I can’t change permissions on the directory. Am I on the right lines here, is there anything that can be done?

          Also categories don’t seem to be preserved when a package is created with packman. Is this how it currently works or am I missing something?

          Any advice much appreciated as I’m guessing a bit at the moment.
          Thanks

            • 32699 ☆ A M B ☆
            • 427 Posts
            Is it possible to have Packman create a Transport Package, which automatically creates and/or populates a database table?

            I have only recently installed it and typically perform these actions manually, or through the whole _build process.

              Get your copy of MODX Revolution Building the Web Your Way http://www.sanitypress.com/books/modx-revolution-building-the-web-your-way.html

              Check out my MODX || xPDO resources here: http://www.shawnwilkerson.com