We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 26903
    • 1,336 Posts
    Would it be possible to preserve the ID numbers of the resources so internal links don’t break
    Theres a ticket raised in github for just this, will be in the 1.9 release which hopefully should be next week sometime.
      Use MODx, or the cat gets it!
      • 436 ☆ A M B ☆
      • 265 Posts
      Perfect!

      From just experimenting over the last 10 minutes I’ve noticed the migration has stalled, the loading bar keeps looping:



      I opened another Manager window and it seems its imported about half the Resources and only a handful of the Elements - would it be possible to implement some kind of log file or even the Revo Consol to see where its got stuck?
        MODX Ambassador for Thailand. Managing Director at Monogon, a web design and development studio based in Bangkok, Thailand. - Follow me on Twitter.
        • 26903
        • 1,336 Posts
        Yes, either of these is doable, in theory however it shouldn’t get stuck of course, hopefully with the some character collation fixes and other stuff going into 1.9 and testing with real users evo sites these bugs should be squeezed out. It won’t return after 5 mins BTW, if the import hasn’t happened in that time frame the mechanism times out and you have to refresh the page to make it work again.
          Use MODx, or the cat gets it!
          • 436 ☆ A M B ☆
          • 265 Posts
          Hmm yeah, this site has got a lot foreign characters in the content, maybe it choked on that - Also this site has over 1,000 Resources and about 50 elements, so perhaps it did timeout or run out of memory?

          I’m happy to help test this over and over again as I could really do with this massive site moved over to Revo.

          Another weird bug, I wiped the Revo install clean and began the import process again to see if the loop was a one-off. Unfortunately it was’t; when I reloaded the Manager I got this on the front- and back-end of the site:





          I cleared the browser cache but the problem was still there - but it loads fine in another browser...
            MODX Ambassador for Thailand. Managing Director at Monogon, a web design and development studio based in Bangkok, Thailand. - Follow me on Twitter.
            • 26903
            • 1,336 Posts
            Yes, hopefully the fixes I’m putting in will get over these probs(thanks for these from user vhollo), I may also make the timer variable, very large sites are also something I’ve not yet tested with, I’ll raise a ticket for this, hopefully by say next weekend we’ll have a 1.9 release.
              Use MODx, or the cat gets it!
              • 33976 ☆ A M B ☆
              • 571 Posts
              Hi,

              tried to play a little bit with Evo > Revo but unfortunately connection failed (claiming the revogateway isn’t installed) and got the following errors in the logs
              [2010-12-02 12:22:07] (ERROR @ "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php : 754) PHP warning: curl_setopt() expects parameter 1 to be resource, null given
              [2010-12-02 12:22:07] (ERROR @ "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php : 755) PHP warning: curl_setopt() expects parameter 1 to be resource, null given
              [2010-12-02 12:22:07] (ERROR @ "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php : 757) PHP warning: curl_exec() expects parameter 1 to be resource, null given
              [2010-12-02 12:22:08] (ERROR @ "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php : 779) PHP warning: Invalid argument supplied for foreach()
              [2010-12-02 12:22:08] (ERROR @ "siteroot"/core/model/modx/modconnectorresponse.class.php : 128) Recoverable error: Argument 1 passed to modConnectorResponse::outputArray() must be an array, null given, called in "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php on line 793 and defined
              [2010-12-02 12:22:08] (ERROR @ "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php : 674) PHP warning: curl_setopt() expects parameter 1 to be resource, null given
              [2010-12-02 12:22:08] (ERROR @ "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php : 684) PHP warning: curl_setopt() expects parameter 1 to be resource, null given
              [2010-12-02 12:22:08] (ERROR @ "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php : 686) PHP warning: curl_exec() expects parameter 1 to be resource, null given
              [2010-12-02 12:22:08] (ERROR @ "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php : 698) PHP warning: Invalid argument supplied for foreach()
              [2010-12-02 12:22:08] (ERROR @ "siteroot"/core/model/modx/modconnectorresponse.class.php : 128) Recoverable error: Argument 1 passed to modConnectorResponse::outputArray() must be an array, string given, called in "siteroot"/core/components/provisioner/model/provisioner/provisioner.class.php on line 706 and defined
              


              Any hint welcomed smiley
              Thanks in adavance
                • 26903
                • 1,336 Posts
                You don’t seem to be creating the CURL resource, check that the directory /assets/components/provisioner/tmp exists and it is writeable by your web server. A file named CURLxxx is created on every login attempt, is this happening?
                  Use MODx, or the cat gets it!
                  • 33976 ☆ A M B ☆
                  • 571 Posts
                  Yes, created the tmp folder and there are 0byte files in it, but it still yells at me saying there’s no revogateway.
                  By the way it’s on a debian squeeze box and php’s been updated recently (5.3.3-4)… i guess it should inspect the changes
                    • 26903
                    • 1,336 Posts
                    OK, check you are using the correct URL, this should just be the URL of theremote evo site, NOT the path to the gateway. Also check your evo installation, you should have a directory named revogateway in /assets/snippets, this should contain an index.php file and a connectors directory.
                      Use MODx, or the cat gets it!
                      • 33976 ☆ A M B ☆
                      • 571 Posts
                      Ok, now i feel ashamed… (i put the revogateway folder in /assets/ not /assets/snippets/)
                      While it’s in the correct place, everything seems to work flawlessly ^^
                      Sorry for the noise, and much thanks for your help